[Gllug] Corrupt directory

David L Neil Mailing list a/c GLLUG at getaroundtoit.co.uk
Thu Jul 17 21:48:52 UTC 2008

Thanks to so many people.

In all the playing about un/re-installing bits and bobs I've wrecked
Gnome (and the Pixies are about to come out on strike), so I'm going to
blitz the machine now/tomorrow. Whether I rebuild with SuSE or move
along is another question...

Damion: comments below:-

damion.yates at gmail.com wrote:
> On Thu, 17 Jul 2008, David L Neil Mailing list a/c wrote:
>> Peter Corlett wrote:
>>> On 16 Jul 2008, at 20:28, David L Neil Mailing list a/c wrote:
>>> [...]
>>>> Nautilus won't list the file. At the command line, it is listed
>>>> but  only the fileNM and the "d" for directory is sensible,
>>>> everything else is described with question marks (access, owner,
>>>> group, dates...). rmdir won't shift it. rm responds with: it's a
>>>> directory...
> Until you mentioned the question marks I'd have continued to assume this
> was fixable.
> damion at ahostname:~$ ls -l .gvfs
> ls: .gvfs: Permission denied
> damion at ahostname:~$ ls -ld .gvfs
> d--------- 2 damion damion 4096 Jul 17 20:34 .gvfs
> damion at ahostname:~$ rm -rf .gvfs
> rm: cannot chdir from `.' to `.gvfs': Permission denied
> damion at ahostname:~$ rmdir .gvfs
> So not exactly the same, rmdir worked for a start and I have - rather
> than ? (I assume $LANG isn't set some something bonkers)

=everything set to English during the YaST install. No other files noted
to have been corrupted like this - system works happily for many other
functions, even multimedia.

> I've seen this before on a file/dir and a fsck fixed.  But you need to
> use -f for force fsck to run, otherwise it will assume it's clean.

=yes, but still finds nothing wrong.
(I've been carefully reading up on all these commands and checking the
options where I recognised the command anyway, just to be sure/as a
learning experience. I was carefully working through both e2fsck and
fsck because some report differences with EXT2 or EXT3, so tried this
and both using single-user mode and booting a Knoppix live-CD.

>>> That's quite *special*. I've seen that before and a fsck will
>>> *usually* fix it, but not if the system's even more mangled than
>>> it looks.
> Sometimes it'll keep finding errors and repeat fscks slowly eat your
> disk.  New format and probably new HD needed.

=yes to former. Hoping not latter (only about one year old SATA drive).

>> Sure enough fsck reports the fs as "clean" and process as "succeeded"
>> both at normal boot and single-user mode command line. Booting a Knoppix
>> CD (thanks Chris!) and running e2fsck was similarly an exercise in futility.
> Double check the filesystem .gvfs is in is mounted RW (touch foo in the
> same dir should work).  Try renaming it*, making a new .gvfs and then
> reinstalling gvfs might get things working, but you don't want a bit
> of corrupted filesystem hanging around really.

=tried all this, and failed. Knoppix initially caught me on the mount
for RW issue...

=/var/lib is in the same file system as and mounted as /, and formatted

> *or rename the directory below.

=didn't try this. It would surely have to be the next file, not
(necessarily) the next in alpha sequence. Don't know enough about the
directory structure.

> Damion

=Many thanks,
Gllug mailing list  -  Gllug at gllug.org.uk

More information about the GLLUG mailing list