[Gllug] Fun with Xen (not!)

Greg R. Smith greg at soshal.com
Wed Aug 24 17:08:48 UTC 2011

look up xen multi bridging

xen does some weird things with its bridges - you don't have to use xens 
built in bridging system, but when you don't other things go crazy.

it took me a while to figure it out, but with very little documentation 
about it ~3 1/2 years ago, I managed to get it going.

This link was around -> http://wiki.xensource.com/xenwiki/XenNetworking 
and was helpful.. its one of the first google responses - so you may 
have seen it

but its defs on the right track.

if its xen 4.0, I am not 100% sure - it doesn't work as well.

hope this helps.


On 24/08/11 14:34, Henrik Morsing wrote:
> Hi,
> I'm trying to help my dad out with a weird Xen problem... Set-up has worked for six months but one of the Xen bridges (it seems) has gone into a frequent but intermittent fault.
> IBM server with Xen 3.2.1 has two NICs bonded to a switch. On top of bind0 is five VLANs, only one of this has now gone funny... The VLANs are linked to bridges to the VIFs, which all go into one DomU.o
> So, the faulty one is eth0+eth1 ->  bond0 ->  bond0.16 ->  xenbr16 ->  vif2.2 ->  eth2.
> This morning we decided to create a new VLAN and chain into the domU, as the other ones worked fine, we assumed a new one would also work, so we created bond0 ->  bond0.20 ->  xenbr20 ->  vif3.2 ->  eth2. It doesn't work either...
> I've been trying to trace traffic on the devices ping from a PC into the domU. Basically, it will work from a number of seconds (anything from a couple to in rare ocaasions, thousands) but then incoming ICMP seems to stop at bond0.20, not arriving at xenbr20, and the domU starts sending arp replies (!) out which only shows at xenbr20 (not at bind0.20 or vif3.2!).
> We've trying manually entering arp entries but the arp calls are a red herring really, it's just a symptom of whatever it is that's wrong.
> I'm not that experienced with Xen or bridges... I've tried setting STP on an off but without success. bridge-nf are all set to 1, which I read somewhere they should be.
> Any ideas? He works at a school and all the classroom PCs the teachers use for lesson plans and presentations are out of action, so it's quite critical :(
> Thanks
> --
> Gllug mailing list  -  Gllug at gllug.org.uk
> http://lists.gllug.org.uk/mailman/listinfo/gllug

Gllug mailing list  -  Gllug at gllug.org.uk

More information about the GLLUG mailing list