[Gllug] Hardware problems / good replacements

James Courtier-Dutton james.dutton at gmail.com
Mon Feb 27 16:26:48 UTC 2012

On 27 February 2012 14:39, Phil Reynolds <phil-gllug at tinsleyviaduct.com> wrote:
> On 11/02/12 19:40, James Courtier-Dutton wrote:
>> On 10 February 2012 22:40, Phil Reynolds <phil-gllug at tinsleyviaduct.com> wrote:
>>> Hmmm... how could I check for a system timer problem?
>> Start with a PC that is keeping accurate time that you trust, using ntpd.
>> One way to check the timer is to just type "date" at the command line
>> in the VM and compare it the other trusted machine. Note the
>> difference, to the nearest second or two.
>> Then, wait about 10 mins and try it again, and see how far out it is that time.
>> If the difference is the same both times, you don't have a timer
>> problem, if the time is out, then there is your problem.
>> On problem machines, I saw the time drifting out by more than 10
>> seconds over a 10 minute period, so it is easy to spot.
>> If the time is your problem, you need to look at virtualised
>> clock-source drivers for inside the VM.
> Well, I finally finished the task of bringing my VMs up to date. I've
> also now tried this test. Only in NetBSD did it fail.
> Guest system            Time drift      Messages                Notes
> ============            ==========      ========                =====
> FreeBSD 9.0             0s in 10 min    None                    None
> NetBSD 5.1_STABLE       102s in 10 min  None                    None
> OpenBSD 5.0-stable      1s in 10 min    None                    Note 1
> Debian kFreeBSD 6.0     1s in 13 min    Message 1 below         None
> Debian Linux wheezy     0s in 10 min    None                    None
> Reactos 0.3.14          0s in 10 min    N/A                     None
> Windows 7               2s in 2h10m     N/A                     None
> Message 1:
> ad0: TIMEOUT - WRITE_DMA retrying (1 retry left) LBA=... (number varies)
> (FreeBSD 8.x used to do the same)
> Note 1: OpenBSD result above is with acpihpet* disabled as per the
> suggestion at http://tinyurl.com/7ov4ezw - although with acpihpet*
> enabled, the result is the same, so obviously not significant in this
> case. As it defaults to enabled, I will leave it so.
> These are all still on the qemu-kvm that came with Debian Linux
> squeeze... I have not yet tried the backports, but I intend to do so.

Ok, so updating the VMs to more up to date kernels has cured your
problem on everything except BSD.
For information, my comments/experience regarding the timer were
around Linux and not BSD.
Gllug mailing list  -  Gllug at gllug.org.uk

More information about the GLLUG mailing list