[GLLUG] Small Form Factor PC

Paul Hewlett phewlett76 at gmail.com
Mon Aug 4 17:49:50 UTC 2014

Hi Michael and everybody else

Maybe my dissing of the Shuttle PC was too general. To be specific the
model in question is the XS35GTV2.

The wired ethernet drivers are from Jmicron - the issue in question is
well-described in this link:


and you might notice that I submitted a (hacked) patch to make it work.
This bug was in all distros -
interestingly openelec seemed to work... The patch only worked for one or
two releases before the kernel API
changed in an incompatible way.

In Ubuntu 14.04 the wired ethernet still did not work although the drivers
were meant to be fixed. Googling
revealed that some had fixed this by issuing a suitable ethtool command
(see comment #37 in the launchpad link).

When I executed ethtool the wired ethernet came alive. Interestingly I have
never needed to do it again even across cold reboots - some users have put
the ethtool (with suitable args) in rc.local but I have never needed to.

I thought that this was the end to my problems - however when doing a fresh
install of Ubuntu 14.04 the graphical installer would freeze at random -
keyboard, mouse, Xwindows, and ssh were unusable. Again googling revealed
that others had experienced this - see


This appeared to be a nouveau problem. I got around this by installing the
Nvidia drivers from the terminal window before starting the installation.
-1 to ubuntu for using a graphical installer.

The system now randomly blanks the monitor and no amount of keypressing or
mouse movement will get rid of the black screen. Either my monitor is
broken or the Shuttle PC on 14.04 is not good. I have tried turning off
power management and dpms to no avail.

All of which is a pity because the XS35GTV2 is a beautifully-engineered
completely silent PC.

It is for sale if anybody is interested.:-)

So that is 3 problems. Combine this with a previous Shuttle PC experience
led me to *not* recommend Shuttle.

Others may have different experiences - YMMV.


On 4 August 2014 08:34, michael norman <michaeltnorman at gmail.com> wrote:

> On 04/08/14 06:20, Paul Hewlett wrote:
>> I have been using a raspberry pi with xbmc with some success. However
>> the interface is very laggy and have been investigating a replacement
>> recently. I also have a shuttle PC but would not recommend it as the
>> wired Ethernet drivers for Linux are problematic.
> Don't understand this, I have a shuttle pc running Linux Mint 17 and
> openSUSE 12.3.  I have never had any problem with etherenet.  It has always
> "just worked"  What do you mean by "wired Ethernet Drivers of Linux" ?
> _______________________________________________
> GLLUG mailing list
> GLLUG at mailman.lug.org.uk
> https://mailman.lug.org.uk/mailman/listinfo/gllug

Tel: +44 79 8532 7353
LinkedIn: http://uk.linkedin.com/pub/paul-hewlett/0/629/9b4
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.lug.org.uk/pipermail/gllug/attachments/20140804/81e1f1c7/attachment.html>

More information about the GLLUG mailing list