[GLLUG] Fedora SSH Problem

John Winters john at sinodun.org.uk
Mon Mar 24 20:58:23 UTC 2014

On 24/03/14 20:53, Mick Farmer wrote:
> Dear GLLUGers,
> I run Fedora 19 at home and Fedora 17 at work.  I use SSH to login at
> work from my home machine.  This has worked successfully for over a
> year.
> Due to refurbishment, my work machine was switched off, moved into
> another room, and then restarted.
> Now SSH requests my password rather than using the default rsa public
> key mechanism.  Nothing has been updated on my work machine as now
> Fedora 17 is not supported.  I've looked at the SSH-related files on my
> home machine and it appears none of them has been updated since the
> move.  Nothing else has changed.

Clearly something has changed - it's just a case of working out what. 
My main suspicion would be of permissions on your ~/.ssh directory, or 
the files therein.

Try invoking ssh with the -v option - that might provide you with useful 
extra information.  Similarly, check /var/log/auth.log on the target 
machine to see if it tells you anything.


More information about the GLLUG mailing list