[GLLUG] radvd and vlans

Chris Bell chrisbell at chrisbell.org.uk
Tue Feb 6 20:24:21 UTC 2018

On Tuesday, 6 February 2018 19:20:27 GMT Tim Woodall via GLLUG wrote:
> On Sun, 4 Feb 2018, Tim Woodall via GLLUG wrote:
> > Hi all,
> > 
> > I'm getting some very bizarre behaviour from radvd when I try to add
> > vlan interfaces.
> > 
> > The possibly unusual feature is that the eth0 vlans share a common
> > subnet with eth0. Most people have one subnet per vlan.
> > 
> > Radvd is sitting there ticking nicely advertising on eth0. radvdump also
> > shows I've got some announcements coming in on eth2 but they don't have
> > any useful information in them and I'm not using eth2 for IP (and can
> > disable ipv6 on the interface)
> > 
> > I bring up the two vlans: ifup eth0.100; ifup eth0.102
> > 
> > And suddenly my RA that were going out on eth0 are going out on eth2
> > instead! Adding RA stanzas for eth0.100 and eth0.102 and they all go out
> > on eth2!
> This seems to have been a bug in the version of radvd I was using. It
> wasn't just related to vlans, even adding a new stanza for another
> interface was enough to cause everything to go wrong. No idea quite what
> it was as the bugs I could find reported appear to be related to adding
> an interface - but I was restarting radvd.
> I've upgraded the server and now the RAs appear to be on the correct
> interfaces. Haven't yet had time to try out the vlan stuff again.
> Tim.

Hello Tim,
I have been trying to learn how to do things using shorewall/shorewall6 in a 
box with four ethernet interfaces. I do not have native IPv6, and do not know 
when it will appear without warning, but I am trying to use 6to4 for testing. 
The various facilities such as SixXS all appear to have been discontinued 
within the last year.
I found that multiple physical interfaces appeared in random order in /etc/
network/interfaces until I included the workaround to pre-up check MAC 
addresses in Debian Jessie, but the system has been modified in Stretch so that 
each interface is named according to its location as found using lspci.
I tried to configure everything in shorewall6 but nothing worked as expected, 
so I started from scratch setting things manually step by step. I have not 
managed to use radvd to set an auto default plus a different prefix for some 
interfaces using correctly allocated 64bit addresses based on fd00::/8 
according to RFC4193, 
## ip address add 
appears to accept additional addresses but they did not appear in
## ip address show 
## ip route add
has simply rejected all attempts at routing between the interfaces using any 
preferred prefix.  Everything was as configured in (local only) Bind9.

Chris Bell
Website http://chrisbell.org.uk

More information about the GLLUG mailing list