[GLLUG] Updating

John Winters john at sinodun.org.uk
Mon Feb 18 08:49:13 UTC 2019

On 17/02/2019 17:27, Chris Bell via GLLUG wrote:
> Hello,
> I have a computer running KDE on Debian Stretch that will usually not allow
> aptitude to "u" (update the list of available packages) because /var/lib/apt/
> lists/lock is open. I can delete the lock and then "u", sometimes finding that
> lists were not already up to date. It is one of three computers running Apt-
> Cacher NG which could be locking the lists, two with KDE while the third is
> not running a desktop, but only one shows the problem.
> Any suggestions why? Thanks.

You missed out the crucial information - which one is showing the problem?

Have you tried simply waiting for a few minutes when "apt update" 
reports that the lock is in place?  It's there for a reason and if it's 
locked then almost certainly some other component is in the middle of 
updating things.

There are various packages in Debian Stretch which do this. 
unattended-upgrades is the obvious possibility, but there is something 
else (I haven't yet worked out what) which now does it in conjunction 
with the desktop environment.  Whether it's part of Gnome or Systemd, 
(or a bit of both) I don't know.

When you find the cache is locked, try running top to see what is going 
on in the background.  You'll usually see something busily fetching the 
latest updates.


P.S.  Pet hate - the latest idea that because Windows can't manage 
updates without a re-boot, now Linux has to do a re-boot too.  Uuugh!

More information about the GLLUG mailing list