[GLLUG] Booting biosboot

James Dutton james.dutton at gmail.com
Tue Mar 15 12:10:03 UTC 2022

On Mon, 7 Mar 2022 at 09:15, Henrik Morsing via GLLUG <
gllug at mailman.lug.org.uk> wrote:

> Good morning,
> I have installed CentOS on the latter half of a disk in an old lpatop,
> where the first half conatins Ubuntu.
> The CentOS install, after booting, did not appear to have altered or
> re-installed a boot loader.
> I've read the CentOS manual, which just says you need a biosboot partition
> on BIOS/GPT disks (same does the installer, if you try to remove it), the
> GRUB documentation, which describes you need it, and various online blog
> that generously describe how to create it. Not one bit of information
> described what to do to GRUB to boot it.
> I've tried adding a manual grub.cfg entry to point to gpt#, # being both
> the biosboot partition and the root partition, but nether worked.
> What is the solution here? And is the CentOS installer broken?
You don't mention whether your BIOS is booting using BIOS or UEFI.  It kind
of depends on just how old the laptop is.
You will need a BIOS boot to put the 1st stage GRUB on.  It is more a
recommendation, than a requirement though. It is just safer and easier if
you do have the BIOS boot partition.
The first stage grub goes on the EFI system partition instead.

If you are currently booting into the first half Ubuntu, the answer is then
just to add extra menu items to the Ubuntu grub menus, to boot your Centos.
Another alternative, is just to boot the CentOS install as a Virtual
Machine running on Ubuntu.

Kind Regards

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.lug.org.uk/pipermail/gllug/attachments/20220315/2b13480a/attachment.htm>

More information about the GLLUG mailing list