[Klug-general] Asus X54H review

Mike Evans mike at tandem.f9.co.uk
Sat Apr 28 17:39:17 UTC 2012

So the Toshiba Satellite A30 (which I bought in 2004 for abut £600 if I 
recall correctly) is on its last legs.  The disc has been reporting more 
and more remapped sectors steadily, the micro-switch on one of the 
touchpad buttons is dodgy so you have to press the button ever more 
firmly, and the batteries no longer retain charge.

I have little reason to travel with a computer now and it mostly sits by 
the sofa in the living room and is used for little more than 
web-browsing.  But it's useful to have a machine like that, and after 
perusing the market for a bit I chose an Asus X54H at just under £350 to 
replace it.


   Intel i3 processor
   4Gb RAM
   500Gb Hard disk
   Webcam, Wireless and wired lan, SD/MS/MS Pro/MMC card reader, USB3...
   15" wide format LCD display
   Windows 7 Home Premium and various other add-ons from Asus which 
which I hope never to trouble myself.

The Tosh initially ran Fedora Core 2 and 3, I think I may have installed 
4 on it also.  I still run Fedora on our desktop machine (currently 
Fedora 16) but at some point I tried Ubuntu on the Toshiba and stuck 
with it.  It was my intention to install Ubuntu on the X54H and may yet 
do so.

So How'd it go?

The standard install came with a 27Gb recovery partition, Windows in a 
187Gb OS partition and a data partition of 255Gb.  I fired it up and 
went through the first user set-up stuff and checked that it would 
connect to my wireless network.  It then prompted me to make a backup of 
the factory install, so I started that.  I was a bit shocked to learn 
that this was going to take five DVDs, given that on my desk there was a 
single Fedora DVD with more than I would ever want from an operating 

Dutifully I went through the process, only to be told half way though 
the Windows now wanted to reboot because it had performed a software 
update whilst I was making the backup.  That filled me with confidence. 
  It's that sort of non-joined-up thinking that gets computers a bad 
name.  I also discovered in the process that the button on the DVD 
drawer is not particularly robust as it jammed in the 'pressed' position 
on second use.

By this time I was about up to the eyeballs with Windows.  I was sick of 
being prompted to install trial versions of this or that (bits of MS 
office, some virus checker) and warnings that the included Bing toolbar 
would inform Microsoft of everything I did and that if I didn't like 
that then I'd have to un-install it.  I couldn't wait to scamper back to 
the safety of Linux.

The little manual with the machine gives very little useful information 
- but one useful tidbit is that if you restore you get the option of 
installing into a single partition.  On that basis I decided to leave 
the 27G restore partion, have a single 100G partition for Windows should 
I want it, and dedicate the remainder to Linux.  I would have two 
partitions for OS install, a small /home for testing purposes and a 
larger /home for normal use.  My normal practice is to do an install 
using the little /home and when I'm happy with it change to the larger 
/home with my real data in it.

I hadn't downloaded an up to date Ubuntu iso image but I did have the 
Fedora16 image I am running on the desktop so in a moment of impatience 
I went ahead and used that.  I created my new partition scheme and did 
the basic install and all went smoothly.

Following the creation of a new user I then did the bits for getting the 
stuff that fedora doesn't ship:

   MP3 player (Rhythmbox and codecs)
   Media player (xine and codecs plus libdvdcss)
   Adobe Flash plugin

For all of this I followed the helpful cut-and-paste guide by Mauriat 
Miranda at


I ran Cheese and checked that the webcam is found and it is.  The 
connection to the wireless network was seamless, and the receiver more 
sensitive than the card in the Tosh.  I've tested the SD card reader and 
that mounted automatically so that's fine.

There is a bug in the detection of the touchpad with the kernel 
installed which means that it is detected as a Logitec wheel mouse. 
This means you don't get any edge or multi-touch scrolling and can't 
disable the touchpad whilst typing.  This was, however, resolved with a 
simple yum update, which installed  Kernel-3.3.0-4.fc16 in which the 
correct driver is connected to the touchpad.  Edge or multi-touch 
scrolling can then be configured on a user-by-user basis.  (Currently 
I'm with multi and my partner is using edge - nice.)

As we like to download our mail and I've never bothered to set up an 
internal mailserver we use ssh -X to run thunderbird on our desktop 
machine from the Tosh.  Ubuntu had some magic that meant you didn't have 
to do that in a terminal because it would spot what you were trying to 
do and pop up a box for the password entry.  Although this is not how 
Ubuntu seems to do it, I found that ssh has a handy environment variable 
called SSH_ASKPASS which can be set up to point to an appropriate X11 or 
gnome pop-up application.  I used

   sudo yum install openssh-askpass

to install gnome-ssh-askpass and that works fine.

A quick 'sudo yum install pidgin' gave me an alternative to the 
infuriating epiphany.  Fedora also uses shotwell rather than 
eye-of-gnome as a quick photo viewer, but it works through a directory 
in some random order so I've changed the default app back to eog.

So to summarise progress so far:


   Really light
   good price
   everything working so far


   Flimsy switch on DVD drawer
   Touchpad buttons are really clonky - fortunately I use touch-to-click
   Screen colour balance is way too blue
   Screen is mostly too bright for me too and Fedora is not good at 
controlling this, I'm constantly having to dim it with the function keys.

Given that Fedora 16 is working well for what we need I've not yet found 
the time or had reason to try the re-installation of Windows from the 
recovery partition and then sort out dual boot.  Maybe I never will.


More information about the Kent mailing list