[Nottingham] Debian lilo problems

Tony Leake nottingham at mailman.lug.org.uk
Mon Jul 21 09:08:01 2003


I have just installed Debian for the first time and have some problems with 

Apologies in advance if this turns into a long post but there's a lot of 
'relevant' information

The machine has run Mandrake for a long time but I wanted to try other 
distros so I added a new slave disk (hdd) and installed Suse. Suse installed 
grub, I think on the mbr of hdd as when I booted I got a Suse prompt, if I 
selected 'other linux' I then got my normal Mandrake lilo prompt.

Next I decided to trash Suse and install Debian. I was given the option of 
where to install lilo and I selected hdd. When I rebooted I got a screen 
full of 01 01 01 etc, same from the boot disk. I re-installed Debian, this 
time selecting hda for the boot loader, made another boot disk, same result, 
01 01 01.

I rebooted using rescue and completed the installation and can reboot at any 
time using rescue but no lilo.

I have also tried running mandrake's rescue disk and re-installing it's 
bootloader, changing the bios to boot from hard drive 1 instead of hard 
drive 0 but still the same result.

I don't know if it's relevant but the mother board is a MSI KM2M combo-L 
running a 2.4 gig Athlon and both drives are Western Digital Caviar 20gb .

After searching google I believe it may be something to do with where the 
boot loader is installed but I coudn't find and concrete help.

Thanks for any ideas.

Sign-up for a FREE BT Broadband connection today!