[Nottingham] Debian lilo problems

James Dobson nottingham at mailman.lug.org.uk
Mon Jul 21 17:11:00 2003

I remember getting this problem when I first tried
installing  red hat 5/6 (long time ago). At the time I
think it was a corrupt MBR, you can't normally boot
past the 2GB limit of a HD anyway so the bootable
partition needs to be within that. 

I'd take a disk out and try and get it working with a
single disk then add the second and manually configure
lilo/grub to boot the original distro (if you can
remember the settings). 

I just love the debian installer ;) damn hard to get
it to install, but once on it's great. 

If you still have no joy try another distro just to
make sure it is debian and not a knacked HD.

Which debian version are you trying to install? 3.0,
3.1 or earlier?

James D

--- Tony Leake <tony_leake@hotmail.com> wrote:
> Hi,
> I have just installed Debian for the first time and
> have some problems with 
> lilo.
> Apologies in advance if this turns into a long post
> but there's a lot of 
> 'relevant' information
> The machine has run Mandrake for a long time but I
> wanted to try other 
> distros so I added a new slave disk (hdd) and
> installed Suse. Suse installed 
> grub, I think on the mbr of hdd as when I booted I
> got a Suse prompt, if I 
> selected 'other linux' I then got my normal Mandrake
> lilo prompt.
> Next I decided to trash Suse and install Debian. I
> was given the option of 
> where to install lilo and I selected hdd. When I
> rebooted I got a screen 
> full of 01 01 01 etc, same from the boot disk. I
> re-installed Debian, this 
> time selecting hda for the boot loader, made another
> boot disk, same result, 
> 01 01 01.
> I rebooted using rescue and completed the
> installation and can reboot at any 
> time using rescue but no lilo.
> I have also tried running mandrake's rescue disk and
> re-installing it's 
> bootloader, changing the bios to boot from hard
> drive 1 instead of hard 
> drive 0 but still the same result.
> I don't know if it's relevant but the mother board
> is a MSI KM2M combo-L 
> running a 2.4 gig Athlon and both drives are Western
> Digital Caviar 20gb .
> After searching google I believe it may be something
> to do with where the 
> boot loader is installed but I coudn't find and
> concrete help.
> Thanks for any ideas.
> Tony
> Sign-up for a FREE BT Broadband connection today! 
> http://www.msn.co.uk/specials/btbroadband
> _______________________________________________
> Nottingham mailing list
> Nottingham@mailman.lug.org.uk

Do you Yahoo!?
Yahoo! Calendar - Free online calendar with sync to Outlook(TM).