[Nottingham] nsplugin-wrapper conflicts?

Richard Davies richard at tollyboy.demon.co.uk
Thu Aug 16 08:34:26 BST 2007


anybody know what is going on here? It has got me totally confused (not that 
that is very hard to do)

Trying to install the Nvidia drivers broke libc6 and got into a catch 22 
situation libc6 and libc6-i386 depend on a higher version of each other than 
is available in Debian etch stable. Synaptic reported both as being broken 
and couldn't fix them

added the unstable sources to the /etc/apt/sources-list
apt-get update
apt-get install -f

gave more errors
removed the unstable sources
apt-get update
apt-get install -f

Removed a lot of programs basically all the ia32 stuff and fixed the broken 
depenencies it seems I can now install any 64bit package but there is still 
the following conflict.

Wondering about removing nspluginwrapper or force overwrite any suggestions?

debian:/home/richard # apt-get install ia32-libs
Reading package lists... Done
Building dependency tree... Done
The following extra packages will be installed:
  cpp-4.1 gcc-4.1-base lib32asound2 lib32gcc1 lib32ncurses5 lib32stdc++6 libc6 
libc6-i386 libgcc1 libssp0 libstdc++6
Suggested packages:
  gcc-4.1-locales ia32-libs-gtk libasound2-plugins glibc-doc
The following NEW packages will be installed
  ia32-libs lib32asound2 lib32gcc1 lib32ncurses5 lib32stdc++6 libc6-i386
The following packages will be upgraded:
  cpp-4.1 gcc-4.1-base libc6 libgcc1 libssp0 libstdc++6
6 upgraded, 6 newly installed, 0 to remove and 695 not upgraded.
Need to get 4173kB/21.6MB of archives.
After unpacking 36.8MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get: 1 http://www.mirrorservice.org etch/main libc6 2.3.6.ds1-13 [4173kB]
Fetched 4173kB in 6s (675kB/s)
(Reading database ... 166830 files and directories currently installed.)
Preparing to replace libc6 2.3.6.ds1-8 
(using .../libc6_2.3.6.ds1-13_amd64.deb) ...
Unpacking replacement libc6 ...
dpkg: error processing /var/cache/apt/archives/libc6_2.3.6.ds1-13_amd64.deb 
 trying to overwrite `/usr/lib64', which is also in package nspluginwrapper
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)


"Sufficiently advanced incompetence is indistinguishable from malice."

More information about the Nottingham mailing list