[Nottingham] What happened to my kernel?

Martin martin at ml1.co.uk
Thu May 17 11:17:39 BST 2007

Dan Robertson wrote:
> Hi,
> Yesterday I connected to the internet with Linux
> (Ubuntu 6.06) for the first time. I was happily
> installing a few applications that I needed when the
> Software Updater popped up with a list of updates for
> software. Fine, I thought, might as well get the
> Now my GRUB has new options (before there was the
> kernel, recovery and mem test):
> kernel 2.6.15-28-386
> kernel 2.6.15-28-386 (recovery mode)
> kernel 2.6.15-23-386
> kernel 2.6.15-23-386 (recovery mode)
> (and memory test)
> Sadly trying to click any of them comes up with the
> message:
> root (hd1,0)
> Error 21: selected disk does not exist
> I tried running Ubuntu from the live disk but couldn't
> seem to access any hard drive partitions (first it
> said it couldn't mount, then after i tried to mount
> drives in disk manager, the folders never seemed to
> open).
> Does anyone have any ideas about 1) what's happened,

Sounds like you might have gone in for a full version update. Your 6.06
was in the middle of being upgraded to the latest version 7.xx whatever.
Looks like you got a kernel update at least.

The screensaver may well have crashed during the process but the update
should have continued ok. Pulling the plug may well have scrambled part
of the HDD.

> 2) whether it can be sorted out without
> reinstallation, and if not, 3) whether the disk can be
> accessed to backup a few files before reinstalling?

Possibly, depending on what has been scrambled in what way.

First thing is to check whether the partitions are still there, then do
a fsck, recover your files, and then see if the update can be completed.

Otherwise, you just have to recover from your most recent backup.

Good luck,

Martin Lomas
martin at ml1.co.uk

More information about the Nottingham mailing list