[Nottingham] systemd-resolved Failed to send hostname reply: Invalid argument

Fay Knight fay_knight at zoho.com
Sat Aug 15 13:39:55 UTC 2020

Glad it's working now.  
Just as a precaution I'd suggest setting an immutable flag on /etc/resolv.conf to make sure it doesn't get overwritten again by anything else at next reboot.  

(I had to do this when I was running dnscrypt-proxy, which was a whole other pain in the backside!). 


On 15 August 2020 11:09:43 BST, Phil Bass via Nottingham <nottingham at mailman.lug.org.uk> wrote:
>Thanks, Fay.
>I tried masking systemd-resolvd and rebooted but that didn’t help. Then
>I looked at my /etc/resolv.conf. It was a symbolic link to
>../run/systemd/resolve/stub-resolv.conf, which did not exist. In fact,
>there was no /run/systemd/resolve/ directory at all. I guess that
>explains it (sort of).
>So, I created a minimal /etc/resolv.conf file and Internet access now
>I’m guessing that Linux Mint 20 is broken but very few users notice
>because almost all of them have upgraded from a working earlier
>version. Can anyone here confirm that theory?
>Phil Bass
>phil.bass at icloud.com
>> On 14 Aug 2020, at 13:51, Fay Knight via Nottingham
><nottingham at mailman.lug.org.uk> wrote:
>> Hi Phil,
>> From my limited knowledge of systemd-resolved I don't believe it's
>strictly necessary, so yes disabling it is worth a try. You might need
>to also check the contents of the /etc/resolved.conf file to check that
>it's pointing to a known-good DNS server. Or alternatively you could
>simply restart the machine afterwards and see if it's now reaching the
>> Fay 
>> On 14 August 2020 13:20:58 BST, Phil Bass via Nottingham
><nottingham at mailman.lug.org.uk <mailto:nottingham at mailman.lug.org.uk>>
>> Hi, guys.
>> It was good to meet a few of you on jitsi last night.
>> A few days ago I installed Linux Mint 20 on an old Windows laptop. I
>haven’t fiddled with any settings (my sysadmin credentials are somewhat
>lacking but I can follow instructions 🙂). The machine connects to my
>WiFi but can’t access the Internet. The Logs app contains multiple
>error messages that say:
>> systemd-resolved Failed to send hostname reply: Invalid argument
>> Googling for this error message throws up a GitHub thread
><https://github.com/systemd/systemd/issues/11626> dating from Feb 2019.
>The problem was originally associated with sleep/wakeup in Arch Linux
>but has also been reported as a permanent problem preventing access to
>the Internet and in Ubuntu. There’s no resolution in that thread and
>the last post was yesterday.
>> I’ve also found a thread on a Manjaro forum
>that suggests masking or disabling systemd-resolved and that has solved
>the problem for the original poster. Is that worth a try?
>> Phil Bass
>> phil.bass at icloud.com <mailto:phil.bass at icloud.com>
>> -- Sent from /e/ Mail.-- 
>> Nottingham mailing list
>> Nottingham at mailman.lug.org.uk <mailto:Nottingham at mailman.lug.org.uk>
>> https://mailman.lug.org.uk/mailman/listinfo/nottingham

-- Sent from /e/ Mail.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.lug.org.uk/pipermail/nottingham/attachments/20200815/7736c75d/attachment.html>

More information about the Nottingham mailing list