[Nottingham] systemd-resolved Failed to send hostname reply: Invalid argument

Phil Bass phil.bass at icloud.com
Tue Aug 18 14:59:18 UTC 2020

It’s working now, but I still don’t really know what the problem was or whether it will come back. Here’s what I’ve done …

First, I re-installed Linux Mint 20 from the bootable USB stick I had created, overwriting the old installation. That gave me a /etc/resolv.conf that was a symlink to /run/systemd/resolve/stub-resolv.conf and, this time, that file did exist and it contained the expected content (DNS server at At this point Internet access worked.

A couple of hours later when I came back to the machine I had no Internet access. DNS lookups were failing.

I then spent a few hours browsing all the relevant information I could find using my Mac without getting much wiser. Eventually, I shut down the laptop and went to bed. The following day when I booted the laptop it had Internet access again. I thought I’d take the opportunity to install the updates that were available. It got part way through downloading the packages and then failed - once again, DNS lookups weren’t working. (I’m not certain now but I don’t think there was a sleep/wakeup event and the /etc/resolv.conf file didn’t change.)

I’d had a similar experience years ago when I lived in York. Different house, different machine, different OS, different router, different ISP, but the same symptoms - frequent DNS failures. We never got to the bottom of the problem then but it went away when I set the router to use the Google DNS servers.

Today I did two things: 1) I removed the dud battery from the laptop to get its part number and order a new one, 2) I connected the laptop to the router through an Ethernet cable instead of relying on the WiFi. And, so far, it’s been working. I’ve been able to download and install the remaining update packages, download a few extra packages that the Update Manager said I should have, and use Firefox to browse the Web.

I hope that’s the end of the story. 🤞

Phil Bass
phil.bass at icloud.com

> On 16 Aug 2020, at 11:23, Phil Bass via Nottingham <nottingham at mailman.lug.org.uk> wrote:
> It seems I spoke too soon. My minimal /etc/resolv.conf only worked until NetworkManager re-wrote it (probably on sleep/wakeup).
> I suppose I could set the immutable flag on /etc/resolv.conf but that doesn’t feel like the right solution. I’ll do some more research, but not today.
> Phil Bass
> phil.bass at icloud.com <mailto:phil.bass at icloud.com>
> -- 
> Nottingham mailing list
> Nottingham at mailman.lug.org.uk
> https://mailman.lug.org.uk/mailman/listinfo/nottingham

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.lug.org.uk/pipermail/nottingham/attachments/20200818/1cba77ee/attachment.html>

More information about the Nottingham mailing list