[sclug]   linux Bluetooth problem

Bob Redknap r.s.redknap at reading.ac.uk
Fri Apr 24 23:09:13 UTC 2020

Matt, thanks for the feedback.

More good news:

I have the BTooth speaker and the BTooth headset both working, and I think all is now under control.

I did install a pulse pavucontrol addon and it gives the necessary volume controls on a GUI. I am quite impressed so far.
One of my problems was forgetting how the BT speaker worked. It has a 3-way switch labelled ‘on/off/bt’ and I was thinking I had to start it on ‘bt’ to pair it and then slide it across to ‘on’ for the playback but that was just stupid as it slides past ‘off’ and hence drops the connection on the way. I don’t really know what the ‘on’ is for, frankly.

Anyway, another problem was not heeding the loud beep from the BT speaker to indicate a successful pairing. Sometimes it didn’t beep, and sometimes it did. Turns out I needed to try 2 or 3 times, switching it from ‘off’ to ‘bt’, to get the connection.  On the linux side in Bluetooth Manager, after a search is toggled, it shows up as a ‘vibro-speaker’. But that doesn’t mean that it is properly connected. It needed a menu ‘setup’ each time to make the connection  - choosing ‘ignore pairing’ and using ‘a2dp’ for the audio stuff.

The BT headset shows up as ‘manhattan’ in Bluetooth Manager and connects fine each time, using the same menu setup method . Linux sees the extra microphone but I haven’t tested that.
I intend to write up a basic how-to with details on the minimal extra addons needed to make it work. But today I got side-tracked half-way through a clean install of Peppermint 3 by the old Dell randomly shutting down … I just stripped out the PSU to test it and it seems fine so I don’t know what this next problem is.

It will take me a few more days of tinkering and testing.

One thing is interesting :  if I start multiple audio wav tracks, via File Manager, on a CD and it will play them simultaneously  – quite a racket. I associated the tracks to open with ‘aplay’ I think.
But there is no way to stop a track playing … it just carries on to the end. I guess that’s where the special audio apps come in. I aim to play around with VLC at some point to see if that controls the music selection and playback etc.


From: matt johnston <insecure.email at virgin.net>
Sent: 24 April 2020 17:44
To: Bob Redknap <r.s.redknap at reading.ac.uk>; Steven De Souza-Wilson <steven at desouza-wilson.com>
Cc: sclug at sclug.org.uk
Subject: Re: [sclug]   linux Bluetooth problem

Hi Bob,

Run pavucontrol on the commandline, not sure it installs by default with pulse (but should).

Good luck!


On Thu, 2020-04-23 at 21:45 +0000, Bob Redknap via Sclug wrote:
Just a follow up.
The good news …
I used the Software Manager on Peppermint 3 to install PulseAudio (again), along with various pulse addons and plugins from a long list of options, if the name suggested a link to Bluetooth.

After rebooting, I opened up the Bluetooth Manager shortcut from the desktop. It already saw the BT speaker from previous pairings, and when I selected a music track from an audio CD it did play it through the BT speaker ! Amazing.
But it was too loud and the default desktop volume control moved up and down, and did nothing. A pop-up said to use a volume control on a pulseaudio mixer, but I can’t see the mixer anywhere. Maybe it’s a command line thing.

The bad news …
I turned off the BT speaker, turned it back on … and it won’t play.

At least I did hear something. Getting closer …


From: Steven De Souza-Wilson <steven at desouza-wilson.com<mailto:steven at desouza-wilson.com>>
Sent: 23 April 2020 13:43
To: Bob Redknap <r.s.redknap at reading.ac.uk<mailto:r.s.redknap at reading.ac.uk>>
Cc: sclug at sclug.org.uk<mailto:sclug at sclug.org.uk>
Subject: Re: [sclug] linux Bluetooth problem

Hi Bob

First thing i would do is confirm thst the speaker is workong, by pairing to a phone. I have actually had this start a similar speaker start working with other devices in tbe past


---- On Thu, 23 Apr 2020 13:11:50 +0100 sclug at sclug.org.uk<mailto:sclug at sclug.org.uk> wrote ----
Hello Sclug,

From a long-time not-so-active member on this list, I would be grateful for any suggestions on how I might fix a Bluetooth problem.

I  have Peppermint 3 (on a couple of old tower boxes with different m/b’s: one is a Dell Dimension 2400 and the other a hybrid) and an unused Bluetooth speaker.
Sound from an audio CD comes out of the headphone socket and ‘Bluetooth Manager’  does pair and talk to the BT speaker saying ‘success’ when prompted, and it shows bytes have passed up and down the link.
But no sound ever reaches the BT speaker.
I can activate sound on the command line using e.g. aplay test.wav and this comes out of the headphone socket OK.

I think maybe it needs an extra plugin/addon/widget but I don’t know which one.

Peppermint 3 doesn’t seem to have a Sound settings in in its Prefs menu either, which might have been useful to tell it to use a BT output device.
I tried installing a Pulseaudio PAV volume control thing but it didn’t help. In fact, I had to delete pulseaudio altogether on one of the tower boxes to get any sound out of the headphone socket.

I would like to stay with Peppermint 3 and ‘Bluetooth Manager’ if possible, but I do have a variety of live Linux discs with any number of distros, and I would be happy to try one if I knew which one might work with a BT speaker, without a lot of extra fiddling around.

I did try installing parts of bluez, or all of it, but it got a bit confusing, and I didn’t see any GUI control, or how to make it work.
I have tried googling around but no good result so far.

I’m hoping there might be a diagnostic audio utility to run.
I have tried VLC, and a few other audio apps but they don’t seem to find the BT device I guess.

Thanks very much for any reply,

In Reading, Berks

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.lug.org.uk/pipermail/sclug/attachments/20200424/f2cc3f40/attachment-0001.html>

More information about the Sclug mailing list