[Scottish] Acme serial port?

Colin McKinnon scottish at mailman.lug.org.uk
Tue Aug 26 22:17:01 2003

Hi all,

Having acquired a Motorola C350 mobile (the one they keep advertising on the 
telly) I was interested to find a hole in the bottom that matched the cable 
for my camera (now an Olympus 350-Z - I ditched the Kodak cx-4230 as I 
couldn't get it to work reliably with any operating system). Back to the 
plot. So I plug it in. Hey presto, Suse 8.2 asks me if I want to configure 
the new hardware! Cool. So Yast thinks it is a Motorola PRS modem connected 
to /dev/ttyACM4 - I don't go right the way through the process, as it wants 
to set up an ISP for me. I do get a new script: 
/etc/sysconfig/network/ifcfg-ppp0 with the expected parameters.

But I don't want to surf using my 9600 bps phone when I've got a cable modem 
connection; I do want to have a tinker with the phone though - so I fire up 
minicom, point it at /dev/ttyACM4 and it immediately falls over with:
	minicom: cannot open /dev/ttyACM4: No such device
....and indeed there is no /dev/ttyACM4, so I make one (mknod /dev/ttyACM4 c 
166 4) but still get the same error with minicom. Back to Yast, detect 
modems, and the phone is now on ttyACM5. Try minicom again, set to use 
ttyACM5, same error!

Next I try mod_probe acm, check in Yast, phone now appears to be on 
/dev/ttyACM0. I try running minicom - and this time it works like a modem!!

But how do I stop it switching devices like that?