[Scottish] Hoary install - ISA CS4236 and ALSA config?

Harry F Doherty harryfdoherty at yahoo.co.uk
Fri Oct 28 00:07:21 BST 2005


I mentioned this briefly on irc the phrase "world of pain" was used -
thanks for the warning!

I just installed Ubuntu Hoary (5.04) on a friend's desktop as his '98 install
It didn't recognise his soundcard.

I'm pretty sure the mobo's a Dell OptiPlex GX1 (I can't read my own
This has an on board soundcard that's a Crystal Semiconductor Chipset CS4236.

The sound worked under knoppix (v3.3) - dmesg|grep isapnp:
 isapnp: Scanning for PnP cards...
 isapnp: Card 'CS4236B'
 isapnp: 1 Plug & Play card detected total

What I then tried to the best of my recollection*:

# modprobe snd-cs4236
Which didn't complain.

Then I restarted alsa:
# /etc/init.d/alsa restart

Then set all volumes to eleven:
# alsamixer

and tried to play a sound:
# aplay /usr/share/XXX/XXX.wav
which then just hung there in silence.

Do I need to configure the driver with the right resource options?
Or unload the current sound drivers?
Or configure the soundcard using isapnp?

Yes, I did then give up and stick a pci soundcard in an Ensoniq ES1371.
I disabled the on board soundcard in BIOS tried 
modprobe/restart/alsamixer/aplay again - still no sound.

Someone had _exactly_ the same problems as me:
but infuriatingly didn't post a solution, just:
	I got it to work! It was the problem with the two sound cards. After
	fiddling about a bit with the isa setting I finally have sound. Thanks

I found:

which suggested using the following for debian:

# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-cs4236
# module options should go here

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

but I'm not sure that applies to Hoary and what do I put as module options?
Should I use sndconfig or alsaconf or not?

Knoppix also has in dmesg:
ad1848: ISAPnP reports 'WSS/SB' at i/o 0x534, irq 5, dma 1, 3
so maybe I could try the configs above with:
options snd-cs4236 dma1=1 dma2=3 io=0x0534 irq=5
or does that only work because isapnp configured the soundcard?

Sorry for the long email, clearly I need to experiment some more.
Any clue would be gratefully appreciated!


* with hindsight I should have had the foresight to run script(1) or
email myself the .bash-history or something.

How much free photo storage do you get? Store your holiday 
snaps for FREE with Yahoo! Photos http://uk.photos.yahoo.com

More information about the Scottish mailing list