[SWLUG] lost and got back CUPS then cannot reinstall driver

Neil Greenwood neil.greenwood.lug at gmail.com
Sat Mar 20 20:12:24 UTC 2010

On 18 March 2010 08:57, Stephen <stephanos at writeme.com> wrote:
> Dear Neil
> Lots of good advice, thanks.
> On the PC I tried the:
>   sudo apt-get install cups=1.3.9-17ubuntu3.4 and got the following
> stephanos at dell:~$ sudo apt-get install cups=1.3.9-17ubuntu3.4
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> E: Version ‘1.3.9-17ubuntu3.4’ for ‘cups’ was not found
> stephanos at dell:~$
> Next I tried Synaptic and indeed found several entries such as
> cups          1.3.9-17ubuntu3.6
> cups-bsd      1.3.9-17ubuntu3.6
> cups-dbg      1.3.9-17ubuntu3.6
> cups-common   1.3.9-17ubuntu3.6
> libcups2      1.3.9-17ubuntu3.6
> Each noted that version 3.7 was available and when I followed the
> Package > Force Version for each of the above, I was offered 3.7 and
> what I think was a lesser version: 1.3.9-17ubuntu1 (Jaunty).  I tried
> this for the first package cups 1.3.9-17ubuntu3.6 but this did not bring
> the printer option I need.
> I used Synaptic to upgrade to 3.7 but that did not help either.
> Thanks for the assistance.
> Hope to hear from Neil or anyone with further suggestions
> Stephen

Hi Stephen,

I noticed some updates to cups on hardy this evening. I've now got
version 1.3.9-17ubuntu3.9 installed (IIRC, the machine's powered off
now). I don't know what the latest version in jaunty is, but you could
try upgrading and see if that solves your problem.

There's also version 1.4 something in karmic, but that involves a bit
more of an upgrade!


More information about the Swlug mailing list