[Wolves] Apt: package has no installation candidate

Matthew Revell wolveslug at understated.co.uk
Sun Mar 21 13:28:53 GMT 2004


Okay, I've installed Morphix to my hard disk.

Now, I've been trying to do the "apt-get dist-upgrade" thing since last
night. I've tidied up the /etc/apt/sources.list so it only has:

deb http://http.us.debian.org/debian stable main contrib non-free
deb http://non-us.debian.org/debian-non-US stable/non-US main contrib
deb http://security.debian.org stable/updates main contrib non-free

but when I run apt-get dist-upgrade I get told that there's nothing to
upgrade. (I have also run apt-get update before doing this.) Great, I must
have a full up to date Debian system. However, I get another apt-get
problem, any time I try to apt-get install anything I get the message:

Package xxxxxx has no available version, but exists in the database.
This typically means that the package was mentioned in a dependency and
never uploaded, has been obsoleted or is not available with the contents
of sources.list
E: Package xxxx has no installation candidate

I've tried this for lots of different packages and get the same error each
time. Is there a problem with the sources.list that I posted above?

Cheers for any help!


More information about the Wolves mailing list