[Nelug] Mandrake 9.0 - Internet connection sharing - Shorewall firewall

Malcolm Collins malcolm at collins12.freeserve.co.uk
Thu Jan 2 20:12:01 UTC 2003

On Thursday 02 Jan 2003 4:19 pm, Peter Wolfendale wrote

> I'm not familiar with MDK 9 and I'm pretty much a novice myself, however
> if you just want a quick fix you can use IP Masquerading to share your
> internet connection. You need to set up the machine with the internet
> connection as a gateway for the other machine in your network settings,
> you then need to set up a firewall rule to share the connection. There
> are a couple of ways to do this, if you aren't aware there are two
> standardized ways for setting up firewall rules under linux, these are
> ipchains (which is older) and iptables (the newer and probably better of
> the two). I am personally unfamiliar with iptables but I can give you
> the commands to put into the terminal that should enable the rule...
> ipchains -F
> echo 1 > /proc/sys/net/ipv4/ip_forward
> ipchains -A forward -j MASQ -i ! eth0 -s
> This needs to be done every time you restart your machine, and I'm
> unfamiliar with Mandrake so I don't know how you'd best want to do that.
> There may be a standard firewall program which you can use to set
> something similar to this up... or if there isn't you may just have to
> make a shell script that runs these commands.
> Hope this is of some help.
> Pete

Thank you Peter.  Unfortunately Mandrake 9 runs iptables.  It has an auto set 
up firewall (Shorewall), but having run it, it still doesn't work.  It may be 
that I have run the set up more than I should and it needs resetting.  I have 
tried uninstalling and reinstalling the firewall from scratch but that has 
not helped.
That is why I think it is something to do with the /etc/sysconfig/ files

Tonight I have logged into windows on the second machine and found that I can 
log into the webserver set up on the internet access machine, but I still 
cannot get to the web or anything else  ( Oh! I can do the same in Linux too, 
just tried it)  I can even log onto webmin from the other machine, 
( windows and linux. 

It seemd that for some reason I am not getting "forwarded" But in most of the 
places I look ipv4 is set to on (or what ever).  I'll try the newsgroup again 
with my own request and see what comes.

Thanks again

More information about the Nelug mailing list