[Durham] About last night ...

Dougie Nisbet dougie at highmoor.co.uk
Sat Nov 30 22:18:03 UTC 2013

I had replied to this thread but found it lurking unsent in the outbox 
of my iPad. There's a moral there somewhere.

Anyway, thankyou and yes, it's all working now. As the saying goes, when 
you've eliminated the impossible, them whatever's left, no matter how 
improbable, must be the truth. So when an identical macbook pro didn't 
work, it dawned on me that the macbook I brought to the pub had not been 
shutdown since then. It was suspended and the same instance of mysql was 
still running. A side-by-side 'show variables' with the pub-macbook soon 
showed the glaring difference.

Still some work to do. e.g. was tempted to push it live but stumbled 
upon http://www.php.net/manual/en/function.htmlspecialchars.php#112476 
where function htmlspecialchars returns null. That could've been 

But all looking good!

thanks and see you in January.


On 20/11/13 15:55, Dougie Nisbet wrote:
> Thanks for all your help - those who were at last night's NELUG, but ....
> bizarrely, I can't transfer the knowledge.
> I have tried exporting the data to a MAC Mini, and iMAC, and, ANOTHER 
> identical Macbook to the one we used last night. All will retrieve 
> records, will not save data. It's possible to enter data into the 
> fields, but they are not saved.
> So what's different? I don't know. I've dumped the data from the 
> Macbook, and even tried copying the raw files over to other servers. 
> I've included Dave's last minute finding of:
> tried with it and without it.
> I've copied the entire /Library/WebServer structure from the macbook 
> to other machines.
> So what did we do last night on the macbook that I'm missing? Am I 
> going to have to do a Crimewatch like reconstruction of last night's 
> events to try and recall what configuration change was made that seems 
> to be unique to the macbook? I was beginning to think it was hardware 
> specific - but having tried migrating it to an identically specced 
> macbook and having the same problem makes me think that there's some 
> unique config change on last night's macbook.
> Yours stumped,
> Dougie
> _______________________________________________
> Durham mailing list   -   Durham at mailman.lug.org.uk
> https://mailman.lug.org.uk/mailman/listinfo/durham
> http://www.nelug.org.uk/

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.lug.org.uk/pipermail/durham/attachments/20131130/8badd8ee/attachment.html>

More information about the Durham mailing list