[Durham] Help

A Pearson a.pearsonx at zen.co.uk
Tue Apr 26 18:51:53 UTC 2016


Thanks for the prompt reply so far.
It does not seem to be the boot that's the problem as It opens up as far as the scenic pictures that form the Mint desktop.  Its just when I try to log on in the boxes after that when the User Name and Password are rejected so we are not far off actually running.  I should have said that I do not suspect the keyboard as the same happened using the on screen virtual keyboard with the mouse so its not a key change problem.  Password comprises upper and lower case and numerals for strength

I am not sure if you are talking of Knoppix just as a boot loader as I knew of it as a Distro which I think I tried many years back (but did not install) along with SUSE,  Mandrake,  and Ubuntu. 
You are correct in that it is on one single partition taking up the whole disk  but Linux automatically split this into two. It is a 1TB SATA so there is no master and slave but is the first disk when it comes to running the Linux. There is no other Linux working operating system on that disk just the one we are referring to.  All the Linux files are installed on the hard disk so I assume we are past the USB live booting stage. The installation file was an ISO which Linux Format said could be used exactly as it was without further burning to an image and it seemed to go in smoothly. I did get a quick flash of a screen with a line mentioning Grub somewhere along the line, possibly not on the current install but did not have time to take note and I was not interested in using it. Linux was loaded with only one HDD in circuit so as  anything that came with Linux such as any bootloader was not on the Windows disc.
Thanks for your help

----- Original Message ----- 
  From: Jonathan Gowar 
  To: Durham Linux User Group mailing list 
  Cc: A Pearson 
  Sent: Tuesday, April 26, 2016 5:27 PM
  Subject: Re: [Durham] Help

  On 2016-04-26 17:11, A Pearson wrote:
  > Hello
  > Mint Cinnamon 17.3 64 bit from LXF 207 Feb 16
  > Its been a long time since I came to the group as most of the talk was
  > way above my head and I use desktops not laptops as they are easier to
  > modify so that was another reason.
  > I hope I have got the posting right as its many years since last time.
  > Installed Mint OK but it will not recognise password or username which
  > I had installed a few minutes earlier.
  > Typing them in correctly with correct case several times just gave the
  > message that either wrong names had been entered or the case was
  > wrong.
  > I have re installed four times now booting on to a clean HDD and no
  > mistake has been made. During install I went through the process of
  > getting Mint to identify the keyboard which is a Microsoft business
  > model of British format.
  > It is on its own drive dual booted from the BIOS for either the Linux
  > or Win 7 drives. I do not use the Grub bootloaders etc as experience
  > shows that if you remove Linux you lose access to Windows and have to
  > start all over again.
  > I am quite proficient with windows PC's but relatively new with Linux
  > having tried a couple of distros in the last ten years but now wish to
  > make a determined effort with Mint.
  > .
  > Hope you can advise so I can move on. Found nothing definite on Google
  > which was mainly people losing their passwords which is not this case.
  > Thanks in anticipation that you may be able to help me with something
  > not too complicated.
  > Regards
  > Alan.

  Hello Alan,

     Without Grub I think you will need to boot your Linux install on a 
  Live Linux environment.

  I would recommend Knoppix64, it is a Debian based, and has options to 
  boot to command line or GUI.  Any live environment will do though.

  Download the ISO burn to disk or dd to USB, then boot from it.  I'm not 
  sure if your dual BIOS booting will get in the way.  Personally, I'd go 
  back to a single disk boot system, as it removes a layer - the more 
  layers removed the simpler things become.

  If you went with Knoppix, from the boot loader type "knoppix 2" that 
  boots to a command prompt.

  Once booted try this;

  mount /dev/sda1 /mnt
  for i in sys proc dev ; do mount --bind /$i /mnt/$i ; done
  chroot /mnt /bin/bash
  passwd username

  (replace "username" with the actual user :)

  Then enter your password, keep it really simple, like "password" 
  something without symbols or capitals etc.

  Then to finish up:

  umount /mnt/{sys,proc,dev}
  umount /mnt

  Note: I am assuming here that sda1 is your root device, and that it's 
  just 1 large partition.  Without having a Linux install to boot on to, 
  it will be hard to confirm - chicken and egg all over again.

  Any way, once rebooted to Linux attempt a login with your username and 
  password, I can not think of a reason why that would not work.

  To address the BIOS dual-booting issue.  Once you have a working Linux 
  install, switch to a single OS booting BIOS and boot Linux.  From the 
  command line type this:

  sudo update-update
  sudo grub-install /dev/sda

  Again, I am assuming you only have one drive.  It actually only needs to 
  be on a primary drive, but I always put grub about :)

  Upon rebooting Grub will have nicely picked out Windows for you too.

  I hope some of this is helpful, let me know how you get on - Happy 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.lug.org.uk/pipermail/durham/attachments/20160426/f08c8704/attachment.html>

More information about the Durham mailing list