[Gllug] WTF!! More nfs woes - write permission denied on 2 of 3 dirs that previously worked.

M.Blackmore mblackmore at oxlug.org
Mon Aug 23 11:26:04 UTC 2004

Russell Howe wrote:

>On Mon, Aug 23, 2004 at 12:44:07AM +0100, M.Blackmore wrote:
>>In a terminal I'm warned of a read only filesystem
>Does mount's output concur with that?
>/dev/hda2 on / type xfs (rw,ikeep)
>                         ^^
>			 read-write
>/dev/hda1 on /boot type ext2 (ro)
>                              ^^
>			      read-only
>If it's mounted read-only, then you need to mount it with the 'rw'
>option to mount it read-write. 
I had checked that...

>If it still doesn't work, check that the
>desktop is allowed to mount it rw (according to /etc/exports on the NFS
and checked the exports for rw enabled.

and rebooted!

>Otherwise strange and wonderful things may happen.
So it seems. Now that I have fired up again this morning I'm going to 
have another look. A thought passed thru my mind that I'd been running 
YAST on 9.0 as well as checking the fstab and exports with a text 
editor, but had restarted the nfs server and client using the yast 
option. Whilst musing in bed this morning before going to change baby's 
nappy I remembered that I'd had a problem in suse 6 summat that 
sometimes yast would overwrite config files with defaults despite not 
having been told to write anything but simply restart services. Perhaps 
something is happening there ... hang on whilst I start the home server 
... back in a while ...

Gllug mailing list  -  Gllug at gllug.org.uk

More information about the GLLUG mailing list