[Gllug] zaurus problem

brad brad at holidays-4u.co.uk
Tue Jul 27 13:37:45 UTC 2004

----- Original Message ----- 
From: "Ian Norton" <bredroll at atari.org>
To: <gllug at gllug.org.uk>
Sent: Tuesday, July 27, 2004 1:46 PM
Subject: [Gllug] zaurus problem

> Hi Everyone,
> Ive noticed recently that there are a number of zaurus users about,
> I got my zaurus sl5500 about 5 weeks ago, ive been having some bother
> with it.
> when it arrived (5 days after the seller warrenty ran out) from an ebay
> seller in canada it had OpenZaurus 3.2 installed, it all worked except
> that it was flashed to only have 12mb of storage, the rest of internal
> memory was for RAM,
> so there i was, new machine, worked, I started fiddling,
> it was at this point that i found that ipkg isnt as robust as stuff like
> dpkg or apt. i was trying to get my wifi card working (work on my
> laptop) when i read on the openzaurus site that i should try the newer c
> libraries and updated card services. so.. i proceeded to update these
> using my usb network connection.
> well, ipkg didnt seem to realise it filled up the internal storage, so,
> consequently destroyed the c libraries,
> now all i can do is to get it to boot right up to login, and of course,
> without any libs i cant do anything, not even get bash.
> if this were a normal box i might have tried something like
> init=/bin/sash on the end of the kernel command line, but no such luck.
> basically, ive given up trying to fix the install and decided to flash
> the machine to the newer openzaurus 3.3.5.
> well, after experimenting with 4 different CF cards ive not been able to
> flash the device, i can however get into it's diag menu, everything
> seems good and all the tests pass.
> im doing the usual flashing procedure,
> format cf card as fat16, (mkfs.vfat -F 16 /dev/hde1)
> copy the zImage and initrd.bin to the cf card
> unmount it
> put it into the zaurus,
> press c + d and reset while plugged into AC,
> nothing at all happens, not even a blink of an LED.
> as it happens, all of the cf cards i have, turned out to be made by
> toshiba and i have a sneaking suspicion this could be the problem.
> can anyone help? anyone willing to lend me thier CF card known to work
> when flashing one of these?
> my next resort is to send it to sharp, but even if they do pick up the
> phone i expect it would be cheaper to buy another device. grrr...
> regards
> Ian
> -- 
> Gllug mailing list  -  Gllug at gllug.org.uk
> http://lists.gllug.org.uk/mailman/listinfo/gllug

can you format the flash with a windoze box? i have flashed my zaurus 100's
of times and with several different cf cards including 2GB microdrive and
have not had any problems with it.  OZ is sometimes flakey, have you tried
any other images for it? www.killefiz.de/zaurus good for this stuff or
http://www.myzaurus.com/ROMupdate5.asp for the original


Gllug mailing list  -  Gllug at gllug.org.uk

More information about the GLLUG mailing list