[Gllug] Oddity with virt-install

Daniel P. Berrange dan at berrange.com
Mon Sep 22 21:19:28 UTC 2008

On Mon, Sep 22, 2008 at 09:42:28PM +0100, Stephen Nelson-Smith wrote:
> I'm installing a centos 5 xen guest on a centos 5 dom0, using
> virt-install.  I've done this dozens of times before, with the same
> kind of recipe:
> $ virt-install --vcpus=1 -f /dev/VolGroup00/ha-test1 -p -r 256 -n
> ha-test1 --nographics -l
> -x ks= -s 4 --force
> It runs anaconda, and gets to the point where it says a graphical
> installer isn't available; normally a text installer would start, but
> it sits there with a blank screen.
> I've tried without the kickstart script and manually entering the
> values gives the same result.
> Any ideas what's going wrong?

Your installation args appear to be a reasonable - I think most likely
problem is simply not having enough RAM allocated to the guest. You're
using an HTTP source which means it has to load stage2 into RAM (70 MB)
which is pushing your luck with only 256 MB of RAM allocated.

I see you've got a i686 install tree for the guest - if you are trying to
run this on a x86_64 host (ie a so called 32-on-64 install), then make
sure you are using at least CentOS 5.2 - paravirt 32-on-64 is very flaky
in Xen and RHEL-5.2 is first time it was reasonably stable. 

> The odd thing is this worked fine just earlier today!

This makes me think its quite possibly the 32-on-64 problem - that shows
itself as random hangs - it can work perfectly for weeks, and then 
inexplicably stop working for weeks :-(

|: http://berrange.com/     -o-    http://www.flickr.com/photos/dberrange/ :|
|: http://libvirt.org  -o-  http://virt-manager.org  -o-  http://ovirt.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: http://freshmeat.net/~danielpb/    -o-   http://gtk-vnc.sourceforge.net :|
Gllug mailing list  -  Gllug at gllug.org.uk

More information about the GLLUG mailing list