[Gllug] Canon camera uploads

david at gbenet.com david at gbenet.com
Sat Jan 29 02:59:46 UTC 2011

Hash: SHA256

Format the SD Card under Windows. It will remove any pics and all your permissions.
Hopefully the problem will go away :)


David L Neil wrote:
> There seems to be a transfer-ownership issue with files on/from my new
> (to me) Canon digi-cam.
> To upload photos, I transfer the SD card from the camera to my HP
> network-attached Photosmart printer, revealed to the network as a
> Windows share (\\PrinterHostNM\MEMORY_CARD\DCIM\101CANON).
> Nautilus reports Owner, Group, and Permissions as "unknown", both on the
> card/printer, and (surprisingly enough) on the NAS' disk after transfer.
> The transfer process itself is marred by "Error while copying
> "IMG_0007.JPG" [etc] = Permission denied, errmsgs on (not quite) every
> individual file. Yet if I "Skip" it copies the image (apparently quite
> correctly and completely).
> However the Freecom NAS appears to be choking, and responds sluggishly
> both to continuing the original mass-copy instruction, and to SSH
> commands. (The NAS runs a minimal Linux but exposes the disk through
> Samba/a series of Windows shares)
> SSH-ing into the NAS shows the following at the command line [ls]:
> -rw-rw-rw-    1 admin    admin      557040 Jan 28 23:58 IMG_0001.JPG
> ("admin" being the non-root user utilised in the Nautilus
> Connect-to-Server parameters)
> My previous digi-cam was a Sony and transferring images from its
> MemoryStick and in the same manner worked without flagging errors - but
> had the same owner/group/access confusion between Nautilus and SSH.
> I have tried SSH-ing into the NAS and then rsync-ing the images from the
> printer/SD-card, but it makes no different. I'm open to using a
> different, but effective, tool or technique...
> Does anyone else use a Canon digicam and experience the same, or
> (hopefully) have a 'fix' to advise please?

- --
“See the sanity of the man! No gods, no angels, no demons, no body. Nothing of the kind.
Stern, sane,every brain-cell perfect and complete even at the moment of death. No delusion.”
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

Gllug mailing list  -  Gllug at gllug.org.uk

More information about the GLLUG mailing list