[GLLUG] Debian 9 Intel Pro 1000 card problems

James Courtier-Dutton james.dutton at gmail.com
Tue Aug 22 06:48:42 UTC 2017

On 20 Aug 2017 11:47, "Henrik Morsing via GLLUG" <gllug at mailman.lug.org.uk>


I had to reinstall my computer and installed a fresh Stretch Stable on
there and at the same time bought an Intel Pro 1000 GT adapter to take over
from the built-in Realtek 8168 at the same time.

This hasn't worked out very well - the e1000 driver (assuming driver
problem as I bought two Intel cards and they both show this problem), works
for abouut half an hour, then goes into full erractic mode. Ping times all
over the place and dropped packets. Google doesn't seem to reveal anyone
with the same problems. It usually happens around the time the logs shows
an "IRQ 16 happened - nobody cared" message.

Another problem with debian 9, is that both the new Intel card and the old
Realtek now insist on starting in half duplex. Why? I've tried adding the
recommended settings in the module configuration file, but they still do
it. I never had to set full duplex manually after booting - in-fact, in my
20 years of using Linux I've never had to do that...

Any ideas about these two issues?


It is most likely a cable or switch problem. The drivers for that ethernet
chip has been working fine for a long time for a lot of people.

Another option causing the problem could be binary kernel modules such as

Or interrupt conflicts.

Kind regards

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.lug.org.uk/pipermail/gllug/attachments/20170822/2cc990f8/attachment.html>

More information about the GLLUG mailing list