[GLLUG] A weird networking problem. Help!

Alain Williams addw at phcomp.co.uk
Thu Jun 22 16:52:57 UTC 2017

On Thu, Jun 22, 2017 at 05:28:45PM +0100, Greater London Linux UUG wrote:
> I have the most bizarre networking problem and I'm struggling to think
> what could possibly be causing it (other than a failing hack attempt by
> the NSA or the like - I don't think I'd be interesting enough for anyone
> to deliberately try to intercept my communications though)
> The symptoms manifest as failing (outbound, haven't tried inbound while
> it's happening) SSH connections. The SSH connections seem to fail to
> anywhere.  But http and https connections to the same host work fine.
> (and there's no MITM certificate interception happening). Running ssh
> and telling it to connect to a non ssh service fails in the way you
> expect. Running SSH to an ssh service "hangs" and eventually times out.

Have you tried connecting with telnet:

telnet machine.name 22

This might not tell much, but is such a simple test that it is not worth not doing.

This will tell you if it is a ssh problem or a routing/connectivity issue.

Alain Williams
Linux/GNU Consultant - Mail systems, Web sites, Networking, Programmer, IT Lecturer.
+44 (0) 787 668 0256  http://www.phcomp.co.uk/
Parliament Hill Computers Ltd. Registration Information: http://www.phcomp.co.uk/contact.php
#include <std_disclaimer.h>

More information about the GLLUG mailing list