[GLLUG] Problem noticed following the latest update to Debian 8.8.0

John Winters john at sinodun.org.uk
Tue May 9 07:41:46 UTC 2017

On 08/05/17 21:08, Chris Bell wrote:
> On Monday 08 May 2017 20:46:12 John Winters via GLLUG wrote:
>> On 08/05/17 20:40, Chris Bell via GLLUG wrote:
>> [snip query about file permissions on USB stick]
>>> I have tried dismounting and re-mounting the USB stick, but I am not sure
>>> whether this is a KDE quirk, a problem with the USB stick, or something
>>> else.
>> How is your USB stick formatted?  If it's the default FAT-family
>> formatting then it doesn't support permissions.
>> Nothing to do with Debian or KDE.
>> Cheers,
>> John
> That sounds reasonable, it is the original default format, but all the other 
> files with it are shown as 644.
> I have just tried chown to root, with no change seen.

You can't chown on a FAT file system - it has no concept of file ownership.

> I noticed the permissions when I saved the files to the main hard disc and 
> checked. I can change the file permissions on the main hard disc, copy it to 
> another name and save it back to disc as 644, but it will still copy both the 
> files to the USB stick and show mode 755 with all other files showing 644.

Are you sure you're not looking at a directory?  That will have
permissions 0755.

IIRC, the only thing you can change about a file on a FAT file system is
the read-only flag.  Thus you can change permissions from 0644 to 0444
but that's it.

It's a property of the file system - not the file.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 473 bytes
Desc: OpenPGP digital signature
URL: <http://mailman.lug.org.uk/pipermail/gllug/attachments/20170509/38c1e5ce/attachment.sig>

More information about the GLLUG mailing list