[HLUG] BTRFS - no space left on device - or too full to delete

Julian Robbins joolsr1 at gmail.com
Tue Dec 12 20:00:24 UTC 2017


I had an interesting time this week.

i installed Timeshift which is a system restore tool that makes snapshots
of your entire os using rsync or Btrfs if you have it. Great idea I thought
that might get me out of a hole sometime ..

Well actually it left me in a bigger one :-(

Last night I experienced lots of weird goings on and found that there was
no space left on the root  filesystem

But the usual trick of deleting stuff didnt help. I managed to boot into
another os I already had on a different HD on the pc.

This helped quite a bit. I'd installed the main os with Btrfs but ended up
with the situation that Timeshift had filled up my pc too much and I
literally couldn't delete files due to no space left.


I tried a rebalance and this didnt work . I tried the next technique of
making a dummy volume in btrfs as per
cannot run because the filesystem is full

Once I had the new loop volume i did another balance and this time it was
able to relocate 1 chunk out of 31 but this was enough to let me delete
files and rebalance again.

Moral of this story .. There's always a way to fix a problem in Linux

and sometimes trying to fix stuff just isnt worth it.

and lastly I really should read up more on Btrfs volumes sometime ;-)


More information about the Herefordshire mailing list