[IOM] Setting up ADSL

Dylan Smith dyls at dylansmith.co.im
Fri Dec 6 19:33:19 2002


I've got ADSL working on one of my Linux machines (which I intend to use
as a router) with the Alcatel Speedtouch USB modem.

Some tips:
I tried the kernel module first (also upgraded to 2.4.20 at the same
time). It was a complete failure. Whilst the speedmgmt tool worked fine
(because it uses usbfs and not the actual driver), the kernel module
didn't do anything useful - not even any error messages. Also, the kernel
module doesn't compile with a 2.4.20 kernel because it used the deprecated
urb_t typedef, which no longer exists in linux/usb.h. (That's easily
enough fixed - just #define urb_t struct urb in speedtouch.c)

After wrestling with this for a long time and failing utterly miserably, I
discovered that there is in fact a userland Speedtouch driver which uses
usbfs. If you have a recent distro, you can just download this, make, make
install and it works out of the box. The userland Speedtouch driver can be
obtained from:


As I said, if you've got a recent distro, you'll have all the USB, usbfs
etc. support already in your kernel and PPP daemon that'll work - so most
of the stuff in the HOWTO you'll be able to skip. Once I had this driver,
I got it working in about 5 minutes.

Dylan Smith, Castletown, Isle of Man      | Code fast, crash young and
Flying: http://www.dylansmith.net         | leave a beautiful core.
FFE/Elite Universe: http://www.alioth.net |             -- JK (#afe)