[Nottingham] Wireless with Suse 9.1 and DWL-520

vanschoo at speakeasy.net vanschoo at speakeasy.net
Sun Feb 26 22:18:23 GMT 2006


  I'm new to the group and new to Nottingham. Been lurking on the list a couple weeks, and I met some of you at the Ubuntu Linux talk.

  I've been trying to get my Linux PC working with the wireless internet that I have at my apartment here, with no luck so far. If anyone can advise me, I'd appreciate it! Here are the details:

I'm running Suse Linux 9.1 (i586)

The wireless connection has worked before, now I'm trying to get it to work with WEP and a static IP address. It worked at my previous location but that was DHCP, with a router between the machines and a wired ethernet connection.

The Nottingham internet provider has given me 
    * a static IP address
    * subnet mask
    * default gateway
    * preferred DNS IP address
    * Network Name [SSID] (string of letters)
    * Network authorisation mode = "open"
    * data encryption type: WEP
    * Network key (ten hexadecimal digits)

My problem is: There MUST be a way to key this info into YAST so I can connect to the internet. Online searches indicate that my hardware is supported, but my attempts to follow the tips I've seen online have not resulted in success yet.

When I open Firefox, I get the message "www.novell.com could not be found. Please check the name and try again." The novell site is set as home in Firefox. Any url will get a similar message.

I have a D-Link DWL-520 wireless card.

YAST -> Network Devices -> Network Card gives this after it detects network devices:

In upper panel "Available are: Other (not detected)"

In lower panel "Already Configured devices:" lists the following
  * Realtek RT8139
    Configured with address
  * D-Link DWL-520 Wireless PCI adapter, Rev E1
    Configured with address

I think my settings for the Realtek RT8139 chipset are fine since the wireless has worked in the past. I did change it from DHCP to static IP (which is reflected in the YAST configs shown a few lines above.) BTW, it's set to use the "8139too" kernel module.

I'm focusing on the settings for D-Link DWL-520 Wireless PCI adapter.
So far, I have found a place within the YAST menus for all the info items I listed above.
Note - I put the SSID string into a setting labeled 'ESSID' in Suse.

Also there are these settings in place under DWL-520 in YAST:
    * Operating mode = managed (other choices are 'ad-hoc' or 'master')
    * Key input type = hex (other options are ascii, passphrase)
    * channel = Automatic
    * Bit rate = auto
    * Access point = <blank>
    * key length = 128
    * kernel module h/w config name = bus-pci-0000:01:08.0
    * kernel module name = orinoco_pci
    * Domain Search 1 = workgroup ("workgroup" is the name of a local network my PC used to be in when I had it hooked to a router. I have no idea what this should be set to now. The spots for name server 2 & 3, and domain search 2 & 3 are empty.) I also have:

    * Host name = Lobelia
    * Domain name = workgroup

  I suspect that the entries I have in the "Host name and Name Server" area are the problem. Any ideas what to try? 

 - Nancy V.

More information about the Nottingham mailing list