[Nottingham] What happened to my kernel?

Dan Robertson stempswood_dan at yahoo.co.uk
Thu May 17 09:07:58 BST 2007


Yesterday I connected to the internet with Linux
(Ubuntu 6.06) for the first time. I was happily
installing a few applications that I needed when the
Software Updater popped up with a list of updates for
software. Fine, I thought, might as well get the
system up to date, so I started the downloads. 

Didn't quite bargain for how long the process was
going to take...

It was just coming to an end when the screen saver
kicked in. That's annoying. I want to see what's
happening, so I gave the mouse a wiggle to get back to
the desktop... but the screen saver just froze. Hmmm.
Well, it might still be doing it's thing in the
background. Better leave it a few minutes and see if
anything's happened. Nope. (Bear in mind that this is
late at night and I really should be sleeping) Well,
what else can I do but switch the machine off and boot
up again?

Now my GRUB has new options (before there was the
kernel, recovery and mem test):

kernel 2.6.15-28-386
kernel 2.6.15-28-386 (recovery mode)
kernel 2.6.15-23-386
kernel 2.6.15-23-386 (recovery mode)
(and memory test)

Sadly trying to click any of them comes up with the

root (hd1,0)
Error 21: selected disk does not exist

I tried running Ubuntu from the live disk but couldn't
seem to access any hard drive partitions (first it
said it couldn't mount, then after i tried to mount
drives in disk manager, the folders never seemed to

Does anyone have any ideas about 1) what's happened,
2) whether it can be sorted out without
reinstallation, and if not, 3) whether the disk can be
accessed to backup a few files before reinstalling?

Thanks in anticipation!


Yahoo! Messenger - with free PC-PC calling and photo sharing. http://uk.messenger.yahoo.com

More information about the Nottingham mailing list