[Nottingham] Help with Ubuntu 10.10 - Graphical interface crash continued (Barry Allen)

Duncan Fyfe djf at star.le.ac.uk
Mon Dec 6 21:35:34 UTC 2010

On 06/12/10 19:03, Barry Allen wrote:
> Hi Guys,
> Sorry if you get this message twice but I think I didn't report my findings back properly.
> Thanks for all the advice so far. Sorry I didn't realise there was a problem moving from 10.4 to 10.10.
> I think the area I'm getting the problems is in the x.org part. Unfortunately I didn't really understand the stuff on http://ubuntuforums.org/showthread.php?t=1585906. How can I find out about which graphics drivers I need? Can I re-install just this bit or reverse back to a previous version?
> So far I've tried rebooting via an older live CD (Ubuntu 8.04) where I was able to see many of the directories but unfortunately many of user areas gave the message "you do not have permission to read it@ when I tried to copy or click on the directories so copying them to the external drive wasn't possible.
> Does someone know if I can change to root or a user access while using a live CD?
> I also found myself viewing the startup log when I tried to restart the PC. All was OK until it reached the vesa and fbdev area. It seemed to see my hardware but then said trying to go to old probe for each of vesa and fbdev before listing no such device for several lines the fatal server error. screen(s) found, but none have a usable configuration was also mentioned in the log.
> I did manage to boot in failsafe low-graphics mode but it claimed screen graphics card, input device settings could not be detected correctly.
> Tried to use startx but got no such device followed by fatal server error. While in the command line I went to /media but all that is there was cdrom and cdrom0. even when I pulled in a flash drive I didn't get it appear so I don't think it automatically mounted anything.
> Tried the cp line from Christoper but because it didn't see the external drive it came up with an error.
> Is there anyway of reverting back to 10.4 without losing my photos so I can back them up and then re-install?
> Thanks for all the help so far again guys, Is there anything else you can suggest?
Hi Barry,
Let us try this step by step.

STEP 1: Try to backup your photos first:
1. Boot to the command line on your system and log in as you.
2. Insert the USB disk.
3. Leave it a few seconds then type "dmesg".  You are looking
for lines that look a little like the following at the end
of the messages dmesg spews out:

[ 8479.545406] scsi 9:0:0:0: Direct-Access     Flash    Drive UT_USB20 
  0.00 PQ: 0 ANSI: 2
[ 8479.546414] sd 9:0:0:0: Attached scsi generic sg3 type 0
[ 8479.547465] sd 9:0:0:0: [sdc] 508160 512-byte logical blocks: (260 
MB/248 MiB)
[ 8479.548095] sd 9:0:0:0: [sdc] Write Protect is off

It is the [sdc] bit you want - or whatever is between the [].
That is the device your USB disk has been assigned as.

4. I'll assume your disk appears as [sdc] too.
5. Now we know if the data is on a partition or not.
At the command line type:
"sudo fdisk -l /dev/sdc"
and supply _your_ password when asked (not the root password).

This should display a table that looks something like:

    Device Boot      Start         End      Blocks   Id  System
/dev/sdc1   *           1         993      254064    6  FAT16

6. IF the table in step 18 is empty issue the command:
IF the table is like the one above (with a /dev/sdc1) issue the command:

7. Now issue these commands:
"sudo mkdir /media/myusbdisk"
"sudo mount $USBDEV /media/myusbdisk"

Fingers crossed your USB disk is now mounted on /media/myusbdisk
and you should be able to see the contents of the disk there:
"ls /media/myusbdisk"

8. Now you need to find your photos and use sudo to copy them to the
USB disk eg:

sudo cp /home/me/p1.jpg /home/me/p2.jpg /media/myusbdisk

Use as many "sudo cp ..." commands as you need.  You don't have
to do it all inone go.

9. When finished copying issue the command:
sudo umount $USBDEV

and let it complete BEFORE removing the USB disk.

PLAN B (in case PLAN A doesn't work):
10. Boot the live CD and log in.
11. plugin the USB disk.
12. open a terminal

13. Find out where the usb disk is mounted.
In the terminal try "ls /media/".
Normally there will be a directory in there for the USB disk.

14.  Now we are going to build up command in the terminal.
Try not to hit return until we have finished but if you do
just hit the up key to recover what you have typed so far.

15. In the terminal type "#sudo cp " (with the space but leave out the 
double quotes).

16. Navigate to your photos, select the ones you want to copy.
 From the "Edit" menu select "copy".

17. Go to the terminal.  In the terminal "edit" menu select "Paste 
Filenames".  This should add a list of file names for your selected 
files to our command line.  It should look something like:
#sudo cp /home/me/myself/and/i.jpg /home/me/myself/and/you.jpg ...

18. Add a space to the end of the command.

19. Type the name of the USB disk directory (from step 4)
[HINT: type up to the first unique character then hit TAB to
autocomplete the name _and_ resolve any funny characters (like spaces)
which need special treatment when used on the command line]

#sudo cp /home/me/p1.jpg /home/me/p2.jpg /media/my[TAB]

20. Once this is ready go back to the start of the line (HOME key should 
work) and delete the '#' character - that was just there to
prevent accidents.

21. Hit return once.  Then hit return a second time when asked for a 

22. All being well when the command has finished you should be
able to unmount the USB disk with your photos on it.
If not, let us know what it complains about.

STEP 2: Now let us try to get your system to a working state:

23. If you boot your system (not the live CD) and get to the command 
line are you able to log in as yourself ?

24. Assuming you can log in Xorg should create a log file here:
/var/log/Xorg.0.log  Are you able to copy and post it to the list ?

25. Try using "sudo" to take actions as root from the command line.

Try the following command at the command prompt:
"sudo touch /etc/testfile"

It should ask you for _your_ password (not the root password).
If it works then the command:
"ls /etc/testfile"
should show you the empty file you just created.
If it didn't work no file will be created - please report back on this.

26. Assuming sudo works, issue the commands:

"sudo apt-get install xserver-xorg-video-nv"
sudo apt-get remove nvidia-*""

answering "y" at the "Do you want to continue [Y/n]?" prompts.

27. Assuming everything goes well in step 4
Do the following command:
	sudo /etc/init.d/gdm restart

Fingers crossed this should get you back to a graphical
display.  What the above commands do is remove the
binary only nvidia drivers and replaces them with the
Xorg nvidia drivers.  The Xorg drivers do not support
3D very well (if at all) so you won't be able to play
your favorite 3D shootemup but will (hopefully) have a
working system that allows you to backup your photos
and investigate what can be done to get working nvidia
binary drivers.

28. If any or none of this works, shout (again)!

Have fun,

More information about the Nottingham mailing list