[sclug] Uninterruptible sleep

Derek M Jones derek at knosof.co.uk
Sat Dec 3 16:58:12 UTC 2005


Does anybody have any ideas on how I can kill a process that
has entered a D (uninterruptible sleep) state?

It is happening for any command that accesses one of my RAID 5
mounts (mdadm -D /dev/md1 worked fine, mdadm -E /dev/md1
goes into a D+ state).

I can mount and access /dev/md0 and /dev/md2, both of which include
partitions from all the drives that make up /dev/md1.

This happened a few days ago and the system worked fine after a
reboot, until now (it has been up continuously).  I will run a disk
scan after I have shutdown the system.

I have had various processes in a D+ state for 8+ hours.  I would
have expected a disk error to have shown up by now (there is nothing
in the logs showing such a problem).

I hammered /dev/md0 for over a week (almost continuous I/O), it
just seems to be the partition mounted on /dev/md1 having this problem.

Derek M. Jones                              tel: +44 (0) 1252 520 667
Knowledge Software Ltd                      mailto:derek at knosof.co.uk
Applications Standards Conformance Testing    http://www.knosof.co.uk

More information about the Sclug mailing list