[sclug] veeeerrrrryyyy looooong delay booting (initrd)

Will Dickson wrd at glaurung.demon.co.uk
Fri Aug 11 17:51:07 UTC 2006

John Stumbles wrote:
> My nipper's dapper box is now (after he's messed around with it trying 
> to install a 2nd hdd and reinstalling the OS) taking about half an hour 
> to boot up. (It worked OK when he first installed it)
> It seems to hang shortly after grub at the stage of
> initrd [loading] /boot/initrd.something or other
> (I didn't write down the message but I recall the initrd and 
> /boot/whatever bit)
> wassup? I thought initrd sets up a ram disk and loads an image of a 
> basic OS into it to then do the bootup. What could be causing it to take 
> forever?

Some kind of hardware issue? It could be waiting for some kind of 
handshake from the hardware, which isn't coming through. Is he using IDE 
(PATA, not SATA) hard drives? In this case, it's important that the 
jumpers on the drives are set correctly: if the actual situation on the 
IDE bus isn't what the drives have been told, this can cause problems 
(depends on the drive firmware; some are more tolerant than others).

It could even be an IRQ conflict <groan/>. The chances of that depend 
quite heaviliy on the exact hardware config.

How skilled is said nipper? Could he have partially unseated something, 
or knocked something hard enough to introduce a hairline fracture? Have 
you tried booting in VGA mode (rather than the wierd graphical mode 
Dapper goes into halfway though its boot process)?

Finally (just to make your day :-) I've got one box which point-blank 
refused to install on one version of SuSE. It was fine with a previous 
version; now it's fine with Dapper instead. Never did get to the bottom 
of that one. OTOH if it booted Dapper before, it probably isn't anything 
like this.

Have you tried booting the Dapper live CD?


More information about the Sclug mailing list