[sclug] Thunderbird connnection problems

n.a.haughton@bigfoot.com haughtonomous at googlemail.com
Wed Jul 9 18:14:27 UTC 2008

> Stuart Ward wrote:
>> You might try testing that the pop connection works ok. use Telnet to
>> connect to the server.
>> Simple instructions here:
>> http://www.anta.net/misc/telnet-troubleshooting/pop.shtml
> And vice-versa.
> sudo netcat -l -p 110
> +OK
> then do a POP3 Thunderbird download with the server set
> to your own machine.
> First command Thunderbird sends is "CAPA" - I'm not
> familiar with that in POP3 but assume it's asking for
> server capabilities.  +OK as a response didn't seem
> to help.
> Still, you'd at least establish that it's connecting.
> Ed.
I can't telnet to googlemail because it uses SSL. I worked my way though
using openSSL to connect, and I managed to list all the outstanding emails
and download one. So I guess that tells me that Google's POP is working
correctly (as if it wasn't :-) ).

Evolution completely fails to start. I tried reinstalling the packages but
that made no difference. I don't even get the startup wizard that I would

My next port of call was the netcat approach, to test connecting to my own
machine - I've tried setting up an email account pointing at 'localhost' and

sudo netcat -l -v -v -p 110

then getting TB to collect mail on that account. The output from netcat is

listening on [any] 110 ...
connect to [] from localhost [] 36725

and eventually TB times out - no CAPA received. I'm not sure what that tells
me, except that netcat must be intercepting the connection because if I
don't start netcat, TB reports that the connection was refused.

I'm out of my depth here really. Can you advise what to try next?

More information about the Sclug mailing list