[sclug]   linux Bluetooth problem

Bob Redknap r.s.redknap at reading.ac.uk
Thu Apr 23 15:53:36 UTC 2020

I have found out a few more things now … the BT speaker works OK on a windows laptop, and I found a BT headset – it has a similar problem, connects with no sound.

And I found that if I click on the task-bar BT icon I get a different set of options than opening the BT Manager icon on the linux desktop.

And now I see that both headphones and speaker can connect OK (without pairing, as either a headset or audio sink), and I see data pkts incrementing on the icon view, and the BT signal is showing as good, and still no sound ! And both BT devices have been added as a device according to when I click  ‘add device’ option.

I did try using the hifi BT a/d dongle in the headphone socket of the linux box and seeing if sound would go to the BT speaker that route, but I forgot to unplug the other BT dongle from the linux box and I think both me and the linux box got confused at that point.

I have to go pedal a bike for my daily exercise and clear my head … I might have a few more ideas later e.g. trying the 2nd linux box which didn’t have any bluez addons etc.
And I might have to search for the BT instruction manuals to look for more clues about pairing i.e. if the default is 0000 or 1111 or 9999 whatever, although it seems to connect if I tell it to ignore pairing.
And there is an option in alsa to select a ‘device’  ( alsa -D <device-name> )  but  I haven’t found the correct name from the ones showing up in the list using alsa -l.

Alsa sends sounds OK to the m/b headphone socket by default, but I am wondering if it would simultaneously send sound to a BT device, or whether I have to specifically tell alsa to find the BT device that Bluetooth Manager said it had added earlier.  Phew.


From: Steven De Souza-Wilson <steven at desouza-wilson.com>
Sent: 23 April 2020 13:43
To: Bob Redknap <r.s.redknap at reading.ac.uk>
Cc: sclug at sclug.org.uk
Subject: Re: [sclug] linux Bluetooth problem

Hi Bob

First thing i would do is confirm thst the speaker is workong, by pairing to a phone. I have actually had this start a similar speaker start working with other devices in tbe past


---- On Thu, 23 Apr 2020 13:11:50 +0100 sclug at sclug.org.uk<mailto:sclug at sclug.org.uk> wrote ----
Hello Sclug,

From a long-time not-so-active member on this list, I would be grateful for any suggestions on how I might fix a Bluetooth problem.

I  have Peppermint 3 (on a couple of old tower boxes with different m/b’s: one is a Dell Dimension 2400 and the other a hybrid) and an unused Bluetooth speaker.
Sound from an audio CD comes out of the headphone socket and ‘Bluetooth Manager’  does pair and talk to the BT speaker saying ‘success’ when prompted, and it shows bytes have passed up and down the link.
But no sound ever reaches the BT speaker.
I can activate sound on the command line using e.g. aplay test.wav and this comes out of the headphone socket OK.

I think maybe it needs an extra plugin/addon/widget but I don’t know which one.

Peppermint 3 doesn’t seem to have a Sound settings in in its Prefs menu either, which might have been useful to tell it to use a BT output device.
I tried installing a Pulseaudio PAV volume control thing but it didn’t help. In fact, I had to delete pulseaudio altogether on one of the tower boxes to get any sound out of the headphone socket.

I would like to stay with Peppermint 3 and ‘Bluetooth Manager’ if possible, but I do have a variety of live Linux discs with any number of distros, and I would be happy to try one if I knew which one might work with a BT speaker, without a lot of extra fiddling around.

I did try installing parts of bluez, or all of it, but it got a bit confusing, and I didn’t see any GUI control, or how to make it work.
I have tried googling around but no good result so far.

I’m hoping there might be a diagnostic audio utility to run.
I have tried VLC, and a few other audio apps but they don’t seem to find the BT device I guess.

Thanks very much for any reply,

In Reading, Berks

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.lug.org.uk/pipermail/sclug/attachments/20200423/e34e4f8e/attachment-0001.html>

More information about the Sclug mailing list