[Scottish] Procmail problem ("Couldn't create "/var/spool/mail/sjm217")

scottish@mailman.lug.org.uk scottish at mailman.lug.org.uk
Fri Oct 18 12:22:01 2002

Hi All,

My mail on this system is delivered straight to MH mailboxes by exim and works 
fine so I don't want to change that. However I also want to fetch mail from a 
POP3 mailbox and deliver these to MH mailboxes based on the headers.

What I have tried to set up is fetchmail downloading my mail and passing it 
onto procmail, which then delivers the mail to the correct MH mailbox.
My current .fetchmailrc is:
defaults mda "/usr/bin/procmail"
poll pop.ntlworld.com auth password protocol pop3 username "sjmurdoch" 
password "<private>"
My current .procmailrc (for testing) is:
| /usr/opt/nmh/lib/rcvstore +ntlworld

Firstly - are there any problems with this setup? It seems to work (except for 
the problem described below) but are there any conditions where this will fail 
would you recommend any changes?

Secondly - the real problem. Fetchmail invokes procmail for each message 
downloaded, and procmail then displays an error:
"Couldn't create "/var/spool/mail/sjm217"
I don't see why procmail should care where my system mailbox is, since 
should not touch it (I only want it to deal with the mail I pipe to it). My 
mailspool lives on NFS at $HOME/.mail but I don't ever read it since exim puts 
my mail into MH folders. Is there any way to tell procmail to ignore my 
mailspool, or failing that, how can I tell it the correct one?

I have tried setting DEFAULT and MAILDIR but neither of these seem to change 
the initial need to create /var/spool/mail/sjm217 (which I do not have write 
access to)

Ideally I would like to fix this without recompiling procmail or asking the 
admin to do something which needs root privilages (I don't have local root). 
But if all else fails I could put a hacked version in my (ever growing) 

Thanks in advance,
Steven Murdoch.