[Scottish] SuSE 8.2 passwords question

neil sinclair scottish at mailman.lug.org.uk
Wed Aug 27 01:05:01 2003

Thanks for the reply!

No joy on the 'su fiona' thing.

It's probably irrelevant, but the permissions on her directory were slightly 
different from the other accounts  - she had rwxrWxr-x, the other accounts 
rwxr-xr-x. But I may have changed that when putting her data on after 
installing 8.2 - can't remember.

How can I check out the login shell?

Or the correct permissions on her home directory etc?

Or is it less trouble just to delete this 'fiona' account, create another one, 
and direct the new one to use her current home and data? (Does seem like 
cheating, though...)

All her (and my) stuff is backed up, so I'm set up for some serious learning 
here! (And also way out of my depth)

Thanks again -


On Tuesday 26 August 2003 20:31, Colin McKinnon wrote:
> On Monday 25 August 2003 22:15, neil sinclair wrote:
> > Anyway, passwd -S says
> >
> > fiona PS 08/25/2003 1 30 10 5
> >
> > I tried passwd -u fiona, but I got the message
> >
> > Cannot unlock the password for "fiona"!
> Maybe 'cos its not locked (passwd -S would report L instead of P). Looks
> like my man pages a re a little out of date - they don't say what the 'S'
> in the resplonse means. Checking my account reports PS too, and its working
> OK so I guess its not a password problem.
> You say it won't let you assign a new password? I'm guessing that you're
> doing this as 'root' since you've tried with Yast.
> If none, can you 'su fiona' (from your normal login, NOT root) using that
> password? If so, then there may be a problem with her login shell or
> permissions on her home directory.
> Colin
> _______________________________________________
> Scottish mailing list
> Scottish@mailman.lug.org.uk
> http://mailman.lug.org.uk/mailman/listinfo/scottish