[Scottish] Sending display to another machine

Allan Bruce allanmb at f2s.com
Fri Sep 26 11:21:27 BST 2003

----- Original Message ----- 
From: "ray" <rayH at engineering-intelligence.co.uk>
To: <scottish at mailman.lug.org.uk>
Sent: Friday, September 26, 2003 11:06 AM
Subject: Re: [Scottish] Sending display to another machine

> On Friday 26 September 2003 10:40, Allan Bruce wrote:
> > I am getting connected, and I see the backdrop of KDE
> > but just no icons, menus or windows.  Well, sometimes they appear for a
> > milliseconds before disappearing, but mostly they are never there.  I do
> > get the clipboard icon until I click it, and then it disappears too!
> It seems that you are connecting to a running KDE session.  That session
> locally be required to grant permission for access.  The first  X session
> will be 0 which is the default for TightVNC if you do not specify a
> number.
> You do not want to be running KDE when you connect with VNC.  You need a
> VNC service running from xinetd to start kdm, or the Mandrake equivalent.
> This will permit login to a new KDE session via VNC.

I am not running KDE yet, fresh from boot, I still get the same probs.
Although when I start vncserver, it does say

New 'X' desktop os Kes:1

So, maybe it does reckon there is another X session running.  I do connect
to Kes:1 from TightVNC also.  To see if X is running before I start the
vncserver, I tried

    ps -ef | grep X

and X isnt running before I start it.
Still just get the backdrop with the clipboard icon at the bottom until I
move my mouse over it and it goes.

More information about the Scottish mailing list