[Scottish] Advice needed about a Perl/Apache interaction

John Gordon Ollason john at houseofdeer.co.uk
Tue Sep 11 17:19:34 BST 2007

In order to minimise the maintenance of a website I set up a configuration
file using GDBM_file, and accessed it using the tie function in Perl for a
set of cgi-bin scripts.
Everything has worked fine (after the usual messing about remembering to
sort out permissions) under Solaris, and under Debian linux, but I have  
now tried
to use the same method under Debian linux on a different platform and I  
have a problem. Everything
works as I should have hoped that it would when the script is executed
 from the cgi-bin directory, or from anywhere else in my file tree that I
have tried, but when the script is accessed via http as a cgi-bin file,  
the tie simply does not take
place. I have had helpful discussions with support at my ISP and we are at
a loss as to how to proceed. I have checked using the -e test that the  
script sees the file on disk, and it does, and I have checked the  
read-permissions, and the read permissions are correct, and I have no idea  
what is needed to make the tie take place.

I supplied the code of a test script in two earlier versions of this  
request, and both times the mailing list identified the message as spam,  
so I am trying, this time without the code.

 From error messages, the details of the software involved are:

Apache/2.0.54 (Debian GNU/Linux) PHP/5.2.1-0.dotdeb.1 with Suhosin-Patch
mod_ssl/2.0.54 OpenSSL/0.9.7e mod_perl/1.999.21 Perl/v5.8.4

In desperation I ftp-ed the test script to my account on another Debian  
powered server, made the appropriate changes to filenames, leaving  
everything else unchanged, and it worked as expected via http.

Has anybody any idea about what is going wrong?

John O.

More information about the Scottish mailing list