[Sussex] XFree86 keyboard mapping question

Tony Austin tony at gigaday.com
Thu Aug 26 22:15:17 UTC 2004

I have been playing around trying to get á é í ó ú and ñ to work.

And, as you can see I have succeeded.  The vowels just work using the
AltGr key, but I cannot figure out why.  I can find no trace of them in
the xkb/symbols/gb file and after just launching X they do not show up

xmodmap -pk

either.  But if I press them and then go back into xmodmap, they are
automagically there and have assigned themselves to unused keycodes in the
squence that they were pressed.

The only practical way that I have found to get the ñ is to assign it to a
Function key using xmodmap, not ideal but usable.

This isn't the first time that I have tried to get my head around X key
mapping and I always end up in a daze because I can never find any
reference that simply explains what comes from where.

If anyone has any ideas, I would be interested.  I'm using Gentoo, BTW.

Also, in the course of this experiment I tried to find out what keycode
AltGr-n generated using xev.  In gnome-terminal it changes the character
set to graphics.  Is there some special significance to the AltGr-n key


Tony Austin
Gigaday Computing Limited
tony at gigaday.com

More information about the Sussex mailing list