[Wolves] OpenVPN under Ubuntu on both its server & client

Adam Sweet adam at adamsweet.org
Wed Apr 16 17:17:14 UTC 2014

On 16/04/14 17:48, John Rose wrote:
> I'm using Ubuntu 12.04. I don't like using STS releases. I'll upgrade to
> 14.04.
> I've now been able to get Plex to see a /TV folder (with me as the
> owner) & its contents. It looks like there's a bug in Plex preventing it
> seeing the Videos folder setup by Ubuntu in my home folder. I was
> 'corresponding' with someone on Ubuntu Forums about playing video from a
> PC to a TV. He recommended Plex. To play a video 'monitored' by PLex, he
> said:
> "For example, I have a plex server and a number of DLNA client devices
> and DLNA "renderers". Often, the "client" and the "renderer" are the
> same - like Android or WDTV or Roku or Chromecast devices. Using the
> WDTV, when I ask it to connect to a "media server", it shows a list
> available on the LAN, I select "Plex-something" and it shows a
> pseudo-menu with Video, Music and Photos. I select Video and it displays
> Movies, Adult, Videos, Home, and TV. Each of those have been specified
> in the Plex web GUI as "video" content folders. You probably just want
> "videos" if there isn't IMDB metadata you want. TV, Movies **must** be
> separate and content that won't have metadata needs to be separate.
> So ... any DLNA client should "see" the plex server on the network. No
> authentication needed. The chromecast is the only device that I have
> which DOES NOT act like a DLNA client - it is just a "renderer" capable
> of being "streamed at" from a client.
> The Plex web interface doesn't let you "stream at" your TV/media player,
> at least mine doesn't. My TVs are not networked - all I need is for the
> damn TV to be hit with a virus and never patched again. "
> I have no idea from the above what to do in order to play a video from a
> PC to a TV!

I have a WDTV too. I tell it to look for a 'media server' (ie a UPnP
DLNA server) and it shows mine and allows me to play media.

As it happens, I couldn't get Mediatomb to work either when I was having
trouble with minidlna, you might be stuck to get it working without
upgrading. As I said, I never figured out the cause of my problems, it
just started working after I upgraded.

Chromecast is different, it can't look for a DLNA server, you need
something else to send the stream from the DLNA server to the
Chromecast. Have a look at the Android BubbleUPnP app. Annoyingly
Chromecast can't render many media types so I had to set up the
BubbleUPnP server on a PC as an intermediate transcoder and it worked
but playback was unacceptably choppy. I tried 2 PCs which should both be
powerful enough but there was no difference. I suspected wifi
performance might have been a problem but my WDTV uses wifi without any
probs. Also, BubbleUPnP server runs on Java. It was a faff to get Sun
Java installed on Ubuntu.

Your TV might be able to browse for a DLNA server or might not. It might
be limited in what formats it can render also. You could perhaps use
BubbleUPnP to send a DNLA stream at it and see what happens. I've also
used MediaHouse UPnP on Android which has fewer features than BubbleUPnP
but also doesn't have the restrictions that the free version of Bubble
has. You can use one of these two apps to act as the missing link
between library and renderer (ie UPnP server and your TV). Each app will
show you a list of sources/libraries and targets/renderers, you pick one
of each and bingo.

VLC also has a UPnP browser under Playlist > Local Network > Universal
Plug'n'Play, which you can use for testing in the meantime.


> On 16/04/14 17:39, Adam Sweet wrote:
>> On 15/04/14 13:09, John Rose wrote:
>>> Chris,
>>> I don't know what a Roku streaming box is let alone have one. The only
>>> thing that I can think of that might cause this is that I have installed
>>> Plex Media Server in order to play single video files from my
>>> laptop/desktop to my new Sony TV. I've given the TV a fixed ip address
>>> on my home network (i.e. configured my router). I haven't had any
>>> success yet with Plex as it doesn't even want to see my home Videos
>>> folder even though it has permsissions for Others to access it & files
>>> on it have Others' read access. I've tried using minidlna & failed with
>>> it. Any ideas for another ap to do this job?
>> I've used minidlna successfully, but not with a TV. As far as I
>> understand, some TVs can be pretty fussy. Googling for problems with
>> minidlna (a year ago so I can't remember the specifics) turned up some
>> config options that can assist with handling TVs from various
>> manufacturers. Doing the same might help you with minidlna at least. I
>> know Dave Morley runs Mediatomb, so you might try that too.
>> About a year ago, I stayed up til 5am trying to set up minidlna on
>> Ubuntu, (I started at 23:30) and couldn't get it working. I spent
>> another 4 hours the next day, including downloading it from the upstream
>> author's website before giving up.
>> 6 months later I upgraded to the next Ubuntu release, then a month or
>> two later decided to have another go at minidlna and it just worked out
>> of the box after I'd pointed it at media. Still no idea what the problem
>> was, but I can only assume a software bug. It's worked for me since
>> Ubuntu 13.10.
>> Regards,
>> Adam Sweet
>> _______________________________________________
>> Wolves LUG mailing list
>> Homepage: http://www.wolveslug.org.uk/
>> Mailing list: Wolves at mailman.lug.org.uk
>> Mailing list home: https://mailman.lug.org.uk/mailman/listinfo/wolves
> _______________________________________________
> Wolves LUG mailing list
> Homepage: http://www.wolveslug.org.uk/
> Mailing list: Wolves at mailman.lug.org.uk
> Mailing list home: https://mailman.lug.org.uk/mailman/listinfo/wolves


Adam Sweet



-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 263 bytes
Desc: OpenPGP digital signature
URL: <http://mailman.lug.org.uk/pipermail/wolves/attachments/20140416/a9db9fe0/attachment.pgp>

More information about the Wolves mailing list