[Wolves] trying to install pyodb

Adam Sweet adamsweet at gmail.com
Wed May 10 22:12:38 UTC 2017

On 10/05/2017 13:58, Mark Croft Redditch Linux Mint via Wolves wrote:
> http://www.obdtester.com/pyobd
> i have emailed the issue i have with linux mint 18.1 32bit and this software.
> hoping someone here can help with the issue.
> sudo dpkg -i pyobd_0.9.3_all.deb
> [sudo] password for markcroft:
> Selecting previously unselected package pyobd.
> (Reading database ... 1113636 files and directories currently installed.)
> Preparing to unpack pyobd_0.9.3_all.deb ...
> Unpacking pyobd (0.9.3) ...
> dpkg: dependency problems prevent configuration of pyobd:
>  pyobd depends on python-wxgtk2.6; however:
>   Package python-wxgtk2.6 is not installed.

The problem you have here is that python-wxgtk2.6 is too old for your
distro. I'm on Ubuntu 17.04 and I believe Mint 18.1 is their latest so
they're roughly the same:

adam at zoot:~$ apt-cache search python-wxgtk
python-wxgtk-media3.0 - Python interface to the wxWidgets Cross-platform
C++ GUI toolkit (wx.media)
python-wxgtk3.0 - Python interface to the wxWidgets Cross-platform C++
GUI toolkit
python-wxgtk3.0-dev - Development files for wxPython

python-wxgtk2.6 was last in Ubuntu 12.04:


and from what I can work out, Linux Mint 12.

> i have installed the latest version of  python-wxgtk via package
> manager and it still wants the early version of gtk library for
> python?
> how do i force that version into linux mint?

You might try to install it from here:


and see what happens but it will probably need to download a whole lot
more than just that package and you may end up in a mess since you'll be
mixing packages from old and new releases. Alternatively, perhaps you
could put one of the above versions of Linux Mint or Ubuntu on a spare

I'm a bit surprised their latest Linux version doesn't support a recent
Linux distribution but Looking at the package, it was most recently
updated in 2015 and the previous one was 2010. The last real development
was 2004 with only bug fixes since.

You could always try contacting them to ask if they could update the
package to work with python-wxgtk3 but the chances are, if there's no
financial motivation to do so, then they won't. They probably don't have
a Linux developer sitting there doing nothing and updating to a newer
graphical toolkit might not be a quick job.


More information about the Wolves mailing list