[Gllug] Problem compiling slackware pkg

Mike Brodbelt mike at coruscant.demon.co.uk
Mon Jul 10 21:31:04 UTC 2006

On Tue, 2006-07-11 at 00:50 +0600, Emon wrote:

> I am a newbie running Slackware10.2 with KDE desktop & a custom compiled
> 2.6.13 kernel. During installation I tried to make it as slim as
> possible by omitting a lot of (presumably) unnecessary pkgs.

My first suggestion would be to try a different distro. You're making
life a lot harder for yourself than it needs to be by using Slackware,
as you'll need to compile a fair bit yourself. If you're doing this to
learn about Linux, then that's not such a bad thing, but if you want to
get Freevo up and running anytime soon, I'd suggest you try Debian,
which has all the dependencies packaged up for you, with details at

> So I have ended up compiling pkgs for the dependencies
> Here is my problem...
> I use a program called "checkinstall" to make slackware (foobar.tgz) pkg
> from source. All I have to do is run "./configure" & then run the
> command "checkinstall".
> Following the above process I have made a "libdvdread-0.9.6" pkg &
> installed it on my system.


> Now I am trying to make a "lsdvd-0.16" pkg but "./configure" gives error
> about header files.

> checking for DVDOpen in -ldvdread... yes

So, it found the actual library...

> checking for dvdread/ifo_read.h... no

...but not a header file

> configure: error: Header files for dvdread not found

> sh-3.00# ls /usr/include/dvdread/
> cmd_print.h  dvd_reader.h  ifo_print.h  ifo_read.h  ifo_types.h
> nav_print.h  nav_read.h  nav_types.h
> sh-3.00#
> ***********************
> So I tired "./configure --includedir=/usr/include/dvdread"
> But it is still giving me the same error??!!!

The include directory to specify isn't necessarily the directory that
contains the header. If the source file that's referencing the header
contains (as I suspect it might) an include line like:-

#include <dvdread/ifo_read.h>

Then you'll need "./configure --includedir=/usr/include/" - it all
depends on how the source file references the header. Also, the test
that configure is using will be using a temporary source file generated
by the autotools, which makes it harder to track down exactly what's
going on.

> Somebody suggested that I download the sources for these two pkgs again,
> & give it a go, I did that but to no effect :-(
> Frustrated... & suspecting that I may have done something wrong during
> compiling... I downloaded the  "libdvdread-0.9.5-i486-1kjz.tgz" &
> "lsdvd-0.16-i486-1kjz.tgz" pkgs from <linuxpackages.net> and installed

Many precompiled packages include binaries, but not header files, as
they assume you're installing them as prerequisites for other binary
packages, not to compile against. You might need to look for dev
packages as well, though it's been a long time since I used Slackware,
so I'm really not sure.

> My questions is what on earth could possibly be wrong with this
> "libdvdread" pkg?? or could it be because I omitted some pkgs during
> installation..

Possibly because you omitted development packages. However I'll repeat
what I said earlier - you should either prepare yourself for a
frustrating experience learning quite a lot about how the compiler,
linker, and autotools behave or you should switch distribution.


Gllug mailing list  -  Gllug at gllug.org.uk

More information about the GLLUG mailing list