[Gllug] Fedora 16 Startup

DL Neil gllug at getaroundtoit.co.uk
Sun May 6 22:38:57 UTC 2012

Dear Mick,

On 07/05/12 08:51, Mick Farmer wrote:
> Dear Stuart,
> I've looked at more "advice" sights than I've had hot dinners.  My
> current summary of the situation is as follows.

Perhaps Stuart's point was that you didn't tell us this/which sites, 
what you had tried before writing here, etc?

So, amongst the 'hot dinners' did you find the likes of:

"Fedora 16 configure network interface using NetworkManager"

- at which step did things come unstuck for you? ("more information")

Did you go to the horse's mouth? Fedora's docs site is useful and 
in-particular the System Administrator's Guide:

"Chapter 6. Network Interfaces"

Interestingly, this makes no mention (to my quick re-read) of the 
ifconfig command. "Wiser heads" may be able to say if it is being 
deprecated/point us at 'the word'? Certainly the docs underline the use 
of ifup and ifdown!

(personally I find these names a bit annoying in their ambiguity, eg 
coding boolean scripts/procedures beginning with "if" to 'ask a 
question' cf abbreviate "interface" - however that's me!?)

Instead they major on the graphical interface: "Network Connections". 
However many of us are used to the cmdLN methods, (apparently) including 
yourself... (for which there is fair warning in the docs with the 
proviso "experienced" - er, um, here be dragons...)

> File /etc/sysconfig/network-scripts/ifcfg-eth0 is set up for static IP,
> but is never activated.

Does your machine enjoy multiple wired Ethernet ports?
("more information")

> However, Fedora always starts Wired-connection-1 which, I assume, uses
> DHCP by default.  There is no Wired-connection-1 in the scripts
> directory, but the interface is still named eth0 by ifconfig.

To keep us on our toes (or for good reasons explained in the docs...) 
device naming conventions have changed. Did your "hot dinners" include:

"Consistent Network Device Naming"

> nm-connection-editor shows Wired-connection-1 and eth0 as available
> interfaces, but eth0 is shown as not activated while Wired-connection-1
> shows activation which agrees with my login time, etc.

If I understand 'the brave new world' correctly, the "eth0" bits are no 
longer 'it'. These days we're moving to devices identified by UIDs (per 
doc ref-ed above)

Thus "Wired-connection-1" is but a label (and wiser heads than mine can 
probably confirm that so is "eth0"). You can change it to anything you 
like/that suits your NM GUI display. This laptop (upon which I write to 
you) has two wired connection definitions:

"Wired DHCP eth0", and
"Wired Fixed 199".

The first word (somewhat unnecessarily - in the GUI!) separates these 
from the wireless connections*. The second documents the addressing 
scheme employed, and the last gives me the backward-compatibility that 
makes my (aged) memory happy or the last octet of the fixed IPaddr (resp).

* connections, particularly wireless, 'announce' themselves (per DNS, 
etc). However if I arrive somewhere and they've used a meaningless (to 
me) ID, I simply amend the label, eg "Fred" for a friend's network which 
announces the router manufacturer's default still (but not for long!!!)

> So, put simply, my OS is not using the appropriate script, but takes its
> own course of action.  I can't find where this is defined.

So, again under the heading of "more information", why not post# the 
relevant script(s)? (suitably redacted if necessary)

# I think the GLLUG list s/w prefers in-line cf attachments

...and so why don't I? Good question, and I'm uncomfortable that you 

Firstly my LAN features a mix of 'servers' and 'clients'. The network 
s/w I employ is "dnsmasq" (offers both DNS and DHCP functionality, a 
simple sub-set of a multiplicity and complexity of config-options, and 
is considerably easier than the 'enterprise' alternatives (perhaps) more 
usually applied).

In my laziness (and those "wiser heads" may 'lecture' me on this) I 
leave ALL machines on the DHCP default that Anaconda seems to 
auto-install (in all of the Fedora/CentOS/RHEL versions currently used); 
and then I amend the dnsmasq configuration to take the MAC address% of a 
DHCP-applicant. If it is a server-machine, dnsmasq allocates it with the 
fixed IPaddr - and if not DHCP applies.

Accordingly I don't (usually) set up Fedora (et al) interfaces for fixed 
addressing (or claim any skill therein).

Ahah you say: "but you said...199". Correct! I have this one connection 
to a hardware router with no DHCP server and located off my LAN - 
accordingly I had to configure the "subnet.199" script - for which I 
used the GUI "Network Connections" and IIRC it 'just worked'. Which is 
absolutely no help to you...

When I look at the generated script I become nervous because it 
misses-out stuff that is mentioned in Chapter 6, eg "DEVICE=" (see 
above). Do I have something that only works in this one fluke of a 
configuration - or perhaps have the docs yet to catch-up with all of the 
new release's changes - or ... ? So the last thing you want is "the 
blind leading the blind" - or at least that's my story...

Sadly I can't immediately reach that router to bring up the connection 
and then check ifconfig (or whatever) for you.

At the risk of 'teaching grandma', have you been wiping the 
DHCP-allocated IPaddr lease from the DHCP server? Have you been 
re-starting the interface and/or NetworkManager after each edit of the 
(again "wiser heads" may advise on the (un)necessity of this...)

Echoing Mick's criticism:
The more info you provide, the more those "wiser heads" have to work-with.
The more info, the more inclined people are to put in the (voluntary) time.
The more you help 'us'/'them', the more inclined we/they will be to help 
(but it's hard to sift the wheat from the chaff!!!)

Gllug mailing list  -  Gllug at gllug.org.uk

More information about the GLLUG mailing list