[GLLUG] irssi and ssl

Henrik Morsing henrik at morsing.cc
Mon Nov 15 14:39:49 UTC 2021

Hi all,

My ISP started enforcing SSL on their IRC channel, and I have not been able to connect since. I get:

14:33 -!- Irssi: warning Could not verify TLS servers certificate: unable to get local
           issuer certificate

Lots of Googling says a "Certificate bundle" is missing from /etc/ssl/certs. I've copied the file people mention from /usr/share (from memory) to /etc/ssl/certs. /etc/openssl.conf also mentions /etc/ssl/certs, so looks right.

Still not working. Found another discussion where people says to run openssl to pull the certificate from the IRC server and save it in a file and use that. Doesn't work either. 

I may not be entirely clear on what the certificate is for. There is a big difference between a cerificate coming with the OS and one you get from the server you are connection to.

Any ideas? This is on Debian, anyone here use Debian and irssi -ssl? I also tried adding -ssl_capath (or something similar, mentioned in a discussion), but that didn't help either.

Henrik Morsing

More information about the GLLUG mailing list