[Klug-general] Memory Stick

rich-ayres at tiscali.co.uk rich-ayres at tiscali.co.uk
Thu Nov 20 00:37:28 UTC 2008

I think I have broken things a bit more thoroughly than I thought. I 
get a message from the ext fs stick saying it does not reconise 
partition label. I Think I may well have "experimented with that while 
using  cfdisk to repartition the sticks originally. 
In the Morning I will try again and give an accurate report on what I 
can and cant do with the sticks and the error messages encountered.
 By the way I had already tried chmod 755  and all  instructions were 
carried out as root. Thank you all for your response and suggestions I 
am noting and learning
Regards R.

>----Original Message----
>From: browns.postbox at gmail.com
>Date: 19/11/2008 17:49 
>To: <kent at mailman.lug.org.uk>
>Subj: Re: [Klug-general] Memory Stick
>On Wed, 19 Nov 2008 16:33:23 +0000
>"Jeremy Hooks" <jeremyhooks at googlemail.com> wrote:
>> 2008/11/16 rich-ayres at tiscali.co.uk <rich-ayres at tiscali.co.uk>:
>> > Also reformatting failed as device is read only
>> That's a bit of an odd one - were you definitely root (or sudoing)
>> when you tried the reformat?
>> Nathan's fsck suggestion is interesting - though he doesn't mention
>> why you might want to use it.  As you say one stick was ext2
>> formatted, presumably if it wasn't cleanly unmounted (e.g. just 
>> out), it could be marked dirty and then would only be mounted
>> read-only by default until it was checked.  I'm not sure if this 
>> affect the other (presumably vfat) stick.  I have a vague 
>> that this may be related to the sixth field of the fstab.
>I hadn't thought of that, it'll be interesting to see if that is the
>problem. I take it for granted when fsk runs on a normal partition
>that's not been un-mounted cleanly, I guess there would be a log
>message to this affect but possibly not seen with a gui mount tool?
>> BTW a good way to add
>> execute/search permissions to a number of directories is - find ./
>> -type d -exec chmod u+x {} ';'  (this find all files of type 'd'
>> (directories) and executes the command chmod u+x)
>That's the kiddy, I would have ended up with something twice as long
>I'm sure :)
>I should also add a correction to my initial post, I suggested using
>'auto' in the fstab file, this would generate an error if the stick 
>not plugged in, doh!
>Best wishes,
>Kent mailing list
>Kent at mailman.lug.org.uk

Do you value your identity? - http://www.tiscali.co.uk/security


More information about the Kent mailing list